Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

rubinius won't build; complains that it needs MRI or Rubinius to build #385

Closed
chuckremes opened this Issue Jun 23, 2010 · 2 comments

Comments

Projects
None yet
2 participants
Member

chuckremes commented Jun 23, 2010

http://gist.github.com/450113

The gist shows I tried to use 1.9.1p-378 and 1.8.7p-173 (OSX default). It complained about both of them.

I suspect this is related to brixen's recent changes to allow rbx to be built by 1.9.

Member

chuckremes commented Jun 23, 2010

Figured it out... the recent changes should force a call to ./configure. The :which_ruby key is missing from the config.rb file without that step; that missing key causes that error.

Owner

evanphx commented Jun 23, 2010

We'll fix the error message so people know to rerun configure.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment