Stuck "bin/mspec ci -B full --background" during build #93

Closed
jarnold opened this Issue Nov 26, 2009 · 4 comments

Comments

Projects
None yet
4 participants

jarnold commented Nov 26, 2009

Initial build of rubinius with llvm enabled resulted in a hung mspec run. Here is the output:

bin/mspec ci -B full --background
rubinius 1.0.0-rc1 (1.8.7 release 2009-11-25 JI) [i686-apple-darwin9.8.0]
........................................................................................................................................................................................................................................................................................................................................................................................................................................

A dtruss of the process was repeatedly spitting out this message:
__semwait_signal(0x317, 0x0, 0x1) = -1 Err#60

Running "bin/mspec ci -B full --background" again resulted in a clean run.

spovich commented Nov 26, 2009

Seeing this also on OS X 10.6 32-bit (mac mini) with same options. It downloaded a precompiled LLVM.

spovich commented Nov 29, 2009

Just tried again with latest from github and it completed this time. The only thing I changed on my system was that I just installed the macports llvm before trying again so not sure if that made a difference or anything that changed in the last 2 days.

@ghost

ghost commented Dec 3, 2009

This should not be fixed. It was related to the JIT not properly compiling out exception handling.

Owner

evanphx commented Dec 4, 2009

Ack. That was me, evan. I logged in wrong.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment