Permalink
Browse files

Update README.textile

  • Loading branch information...
Michael Klishin
Michael Klishin committed Nov 29, 2012
1 parent ce1a8de commit ce44eaf711f07dc295c44642c3d5e8dd6d7b33e4
Showing with 6 additions and 4 deletions.
  1. +6 −4 README.textile
View
@@ -1,4 +1,4 @@
-h1. About bunny
+h1. Bunny, an easy to use Ruby client for RabbitMQ
Bunny is a synchronous RabbitMQ client. It supports Ruby 1.9.3, 1.9.2, 1.8.7,
Ruby Enterprise Edition and JRuby.
@@ -7,7 +7,7 @@ h2. Limited Functionality Disclaimer
Bunny 0.7.x and 0.8.x releases are not feature complete in respect of the AMQP spec or RabbitMQ.
-You can use Bunny to:
+You can use Bunny 0.8.x to:
* Create and delete exchanges
* Create and delete queues
@@ -20,13 +20,15 @@ But it does not support
* Many AMQP operations
* RabbitMQ extensions
+The next release (0.9.0) will be feature complete, designed for concurrency,
+more efficient and properly documented.
+
h2. Next Bunny release (0.9.0) will include a lot of internal changes
Bunny is lacking some very useful functionality and as such, is about to undergo serious internal changes.
We will make our best efforts to keep the public API as backwards compatible as possible but within reason.
-See "the rationale":https://groups.google.com/forum/?fromgroups#!topic/ruby-amqp/crNVGEuHm68
-and "0.9.0.pre1 release notes":https://groups.google.com/forum/?fromgroups#!topic/ruby-amqp/UMiexQt9Y1Y to learn more.
+See "the rationale":https://groups.google.com/forum/?fromgroups#!topic/ruby-amqp/crNVGEuHm68 and "0.9.0.pre1 release notes":https://groups.google.com/forum/?fromgroups#!topic/ruby-amqp/UMiexQt9Y1Y to learn more.
We are also working on porting amqp gem documentation guides to Bunny at "":http://rubybunny.info. The docs
*cover Bunny 0.9.0* (including `pre` releases) only and are still in early stages.

0 comments on commit ce44eaf

Please sign in to comment.