Permalink
Browse files

Put 1.9.3 support back

  • Loading branch information...
pitr-ch committed Nov 1, 2018
1 parent ea7877d commit 3b3f9bff4eb24dd8bed0112bd79e9b5a338ff2c1
Showing with 200 additions and 93 deletions.
  1. +5 −0 .travis.yml
  2. +8 −0 CHANGELOG.md
  3. +1 −1 Gemfile
  4. +6 −2 README.md
  5. +3 −2 Rakefile
  6. +2 −2 concurrent-ruby-edge.gemspec
  7. +2 −2 concurrent-ruby-ext.gemspec
  8. +3 −3 concurrent-ruby.gemspec
  9. +1 −1 docs-source/signpost.md
  10. +10 −4 docs/{1.1.0 → 1.1.1}/Concurrent.html
  11. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor.html
  12. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/AbstractContext.html
  13. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/ActorTerminated.html
  14. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour.html
  15. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/Abstract.html
  16. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/Awaits.html
  17. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/Buffer.html
  18. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/ErrorsOnUnknownMessage.html
  19. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/ExecutesContext.html
  20. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/Linking.html
  21. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/Pausing.html
  22. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/RemovesChild.html
  23. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/SetResults.html
  24. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/Supervising.html
  25. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Behaviour/Termination.html
  26. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Context.html
  27. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Core.html
  28. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/DefaultDeadLetterHandler.html
  29. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Envelope.html
  30. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/InternalDelegations.html
  31. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/PublicDelegations.html
  32. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Reference.html
  33. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/RestartingContext.html
  34. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Root.html
  35. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/TypeCheck.html
  36. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/UnknownMessage.html
  37. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Utils.html
  38. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Utils/AdHoc.html
  39. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Utils/AsAdHoc.html
  40. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Utils/Balancer.html
  41. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Utils/Broadcast.html
  42. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Actor/Utils/Pool.html
  43. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Agent.html
  44. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Agent/Error.html
  45. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Agent/ValidationError.html
  46. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Array.html
  47. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Async.html
  48. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Atom.html
  49. 0 docs/{1.1.0 → 1.1.1}/Concurrent/AtomicBoolean.html
  50. 0 docs/{1.1.0 → 1.1.1}/Concurrent/AtomicFixnum.html
  51. 0 docs/{1.1.0 → 1.1.1}/Concurrent/AtomicMarkableReference.html
  52. 0 docs/{1.1.0 → 1.1.1}/Concurrent/AtomicReference.html
  53. 0 docs/{1.1.0 → 1.1.1}/Concurrent/CachedThreadPool.html
  54. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Cancellation.html
  55. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Cancellation/Token.html
  56. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel.html
  57. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer.html
  58. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer/Base.html
  59. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer/Buffered.html
  60. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer/Dropping.html
  61. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer/Sliding.html
  62. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer/Ticker.html
  63. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer/Timer.html
  64. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Buffer/Unbuffered.html
  65. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Selector/AfterClause.html
  66. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Selector/DefaultClause.html
  67. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Selector/ErrorClause.html
  68. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Selector/PutClause.html
  69. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Selector/TakeClause.html
  70. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/Tick.html
  71. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Channel/ValidationError.html
  72. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Collection/CopyOnNotifyObserverSet.html
  73. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Collection/CopyOnWriteObserverSet.html
  74. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Concern.html
  75. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Concern/Dereferenceable.html
  76. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Concern/Obligation.html
  77. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Concern/Observable.html
  78. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ConcurrentUpdateError.html
  79. 0 docs/{1.1.0 → 1.1.1}/Concurrent/CountDownLatch.html
  80. 0 docs/{1.1.0 → 1.1.1}/Concurrent/CyclicBarrier.html
  81. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Delay.html
  82. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Edge.html
  83. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Edge/LockFreeLinkedSet.html
  84. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Edge/LockFreeLinkedSet/Head.html
  85. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Edge/LockFreeLinkedSet/Node.html
  86. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Edge/LockFreeLinkedSet/Tail.html
  87. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Edge/LockFreeLinkedSet/Window.html
  88. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Event.html
  89. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Exchanger.html
  90. 0 docs/{1.1.0 → 1.1.1}/Concurrent/FixedThreadPool.html
  91. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Future.html
  92. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Hash.html
  93. 0 docs/{1.1.0 → 1.1.1}/Concurrent/IVar.html
  94. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ImmediateExecutor.html
  95. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ImmutableStruct.html
  96. 0 docs/{1.1.0 → 1.1.1}/Concurrent/IndirectImmediateExecutor.html
  97. 0 docs/{1.1.0 → 1.1.1}/Concurrent/LazyRegister.html
  98. 0 docs/{1.1.0 → 1.1.1}/Concurrent/LockFreeQueue/Node.html
  99. 0 docs/{1.1.0 → 1.1.1}/Concurrent/LockFreeStack.html
  100. 0 docs/{1.1.0 → 1.1.1}/Concurrent/LockFreeStack/Node.html
  101. 0 docs/{1.1.0 → 1.1.1}/Concurrent/MVar.html
  102. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Map.html
  103. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Maybe.html
  104. 0 docs/{1.1.0 → 1.1.1}/Concurrent/MultipleAssignmentError.html
  105. 0 docs/{1.1.0 → 1.1.1}/Concurrent/MultipleErrors.html
  106. 0 docs/{1.1.0 → 1.1.1}/Concurrent/MutableStruct.html
  107. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ProcessingActor.html
  108. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promise.html
  109. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises.html
  110. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/AbstractEventFuture.html
  111. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/AbstractEventFuture/ThrottleIntegration.html
  112. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Channel.html
  113. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Event.html
  114. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/FactoryMethods.html
  115. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/FactoryMethods/Configuration.html
  116. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/FactoryMethods/NewChannelIntegration.html
  117. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Future.html
  118. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Future/ActorIntegration.html
  119. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Future/FlatShortcuts.html
  120. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Future/NewChannelIntegration.html
  121. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Future/ThrottleIntegration.html
  122. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/Resolvable.html
  123. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/ResolvableEvent.html
  124. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Promises/ResolvableFuture.html
  125. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ReInclude.html
  126. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ReadWriteLock.html
  127. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ReentrantReadWriteLock.html
  128. 0 docs/{1.1.0 → 1.1.1}/Concurrent/SafeTaskExecutor.html
  129. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ScheduledTask.html
  130. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Semaphore.html
  131. 0 docs/{1.1.0 → 1.1.1}/Concurrent/SerializedExecution.html
  132. 0 docs/{1.1.0 → 1.1.1}/Concurrent/SerializedExecution/Job.html
  133. 0 docs/{1.1.0 → 1.1.1}/Concurrent/SerializedExecutionDelegator.html
  134. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Set.html
  135. 0 docs/{1.1.0 → 1.1.1}/Concurrent/SettableStruct.html
  136. 0 docs/{1.1.0 → 1.1.1}/Concurrent/SimpleExecutorService.html
  137. 0 docs/{1.1.0 → 1.1.1}/Concurrent/SingleThreadExecutor.html
  138. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization.html
  139. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/Condition.html
  140. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/JRubyAttrVolatile.html
  141. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/JRubyAttrVolatile/ClassMethods.html
  142. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/Lock.html
  143. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/MriAttrVolatile.html
  144. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/MriAttrVolatile/ClassMethods.html
  145. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/Object.html
  146. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/RbxAttrVolatile.html
  147. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/RbxAttrVolatile/ClassMethods.html
  148. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/TruffleRubyAttrVolatile.html
  149. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Synchronization/TruffleRubyAttrVolatile/ClassMethods.html
  150. 0 docs/{1.1.0 → 1.1.1}/Concurrent/TVar.html
  151. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ThreadLocalVar.html
  152. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ThreadPoolExecutor.html
  153. 0 docs/{1.1.0 → 1.1.1}/Concurrent/ThreadSafe/Util/XorShiftRandom.html
  154. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Throttle.html
  155. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Throttle/PromisesIntegration.html
  156. 0 docs/{1.1.0 → 1.1.1}/Concurrent/TimerSet.html
  157. 0 docs/{1.1.0 → 1.1.1}/Concurrent/TimerTask.html
  158. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Transaction.html
  159. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Transaction/ReadLogEntry.html
  160. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Tuple.html
  161. 0 docs/{1.1.0 → 1.1.1}/Concurrent/Utility.html
  162. 0 docs/{1.1.0 → 1.1.1}/_index.html
  163. 0 docs/{1.1.0 → 1.1.1}/class_list.html
  164. 0 docs/{1.1.0 → 1.1.1}/css/common.css
  165. 0 docs/{1.1.0 → 1.1.1}/css/full_list.css
  166. 0 docs/{1.1.0 → 1.1.1}/css/style.css
  167. +13 −0 docs/{1.1.0 → 1.1.1}/file.CHANGELOG.html
  168. 0 docs/{1.1.0 → 1.1.1}/file.LICENSE.html
  169. +8 −2 docs/{1.1.0 → 1.1.1}/file.README.html
  170. 0 docs/{1.1.0 → 1.1.1}/file.promises.out.html
  171. 0 docs/{1.1.0 → 1.1.1}/file.thread_pools.html
  172. 0 docs/{1.1.0 → 1.1.1}/file_list.html
  173. 0 docs/{1.1.0 → 1.1.1}/frames.html
  174. +8 −2 docs/{1.1.0 → 1.1.1}/index.html
  175. 0 docs/{1.1.0 → 1.1.1}/js/app.js
  176. 0 docs/{1.1.0 → 1.1.1}/js/full_list.js
  177. 0 docs/{1.1.0 → 1.1.1}/js/jquery.js
  178. 0 docs/{1.1.0 → 1.1.1}/method_list.html
  179. 0 docs/{1.1.0 → 1.1.1}/top-level-namespace.html
  180. +10 −4 docs/master/Concurrent.html
  181. +13 −0 docs/master/file.CHANGELOG.html
  182. +8 −2 docs/master/file.README.html
  183. +41 −41 docs/master/file.promises.out.html
  184. +8 −2 docs/master/index.html
  185. +13 −11 ext/concurrent-ruby/com/concurrent_ruby/ext/SynchronizationLibrary.java
  186. +2 −0 lib/concurrent.rb
  187. +4 −2 lib/concurrent/atomic/java_count_down_latch.rb
  188. +10 −6 lib/concurrent/exchanger.rb
  189. +17 −0 lib/concurrent/utility/193.rb
  190. +2 −2 lib/concurrent/utility/engine.rb
  191. +2 −2 lib/concurrent/version.rb
View
@@ -36,13 +36,18 @@ matrix:
rvm: 2.1.10
- name: MRI 2.0.0
rvm: 2.0.0
- name: MRI 1.9.3
rvm: 1.9.3
- name: JRuby 9.1.17.0
rvm: jruby-9.1.17.0
jdk: oraclejdk8
- name: JRuby 9.0.5.0
rvm: jruby-9.0.5.0
jdk: oraclejdk8
- name: JRuby 1.7.27
rvm: jruby-1.7.27
jdk: oraclejdk8
- name: MRI head
rvm: ruby-head
View
@@ -1,5 +1,13 @@
## Current
## Release v1.1.1, edge v0.4.1 (1 Nov 2018)
* (#768) add support for 1.9.3 back
## Release v1.1.0, edge v0.4.0 (31 OCt 2018) (yanked)
* (#768) yanked because of issues with removed 1.9.3 support
## Release v1.1.0.pre2, edge v0.4.0.pre2 (18 Sep 2018)
concurrent-ruby:
View
@@ -1,6 +1,6 @@
source 'https://rubygems.org'
require_relative 'lib/concurrent/version'
require File.join(File.dirname(__FILE__ ), 'lib/concurrent/version')
no_path = ENV['NO_PATH']
options = no_path ? {} : { path: '.' }
View
@@ -227,8 +227,12 @@ be obeyed though. Features developed in `concurrent-ruby-edge` are expected to m
## Supported Ruby versions
MRI 2.0 and above, JRuby 9000, TruffleRuby are supported.
This gem should be fully compatible with any interpreter that is compliant with Ruby 2.0 or newer.
* MRI 2.0 and above
* JRuby 9000
* TruffleRuby are supported.
* Any Ruby interpreter that is compliant with Ruby 2.0 or newer.
Actually we still support mri 1.9.3 and jruby 1.7.27 but we are looking at ways how to drop the support.
Java 8 is preferred for JRuby but every Java version on which JRuby 9000 runs is supported.
The legacy support for Rubinius is kept but it is no longer maintained, if you would like to help
View
@@ -2,6 +2,7 @@
require_relative 'lib/concurrent/version'
require_relative 'lib/concurrent/utility/engine'
require_relative 'lib/concurrent/utility/193'
core_gemspec = Gem::Specification.load File.join(__dir__, 'concurrent-ruby.gemspec')
ext_gemspec = Gem::Specification.load File.join(__dir__, 'concurrent-ruby-ext.gemspec')
@@ -16,8 +17,8 @@ class ConcurrentRubyJavaExtensionTask < Rake::JavaExtensionTask
jruby_cpath = nil
if RUBY_PLATFORM =~ /java/
begin
cpath = Java::java.lang.System.getProperty('java.class.path').split(File::PATH_SEPARATOR)
cpath += Java::java.lang.System.getProperty('sun.boot.class.path').split(File::PATH_SEPARATOR)
cpath = Java::java.lang.System.getProperty('java.class.path').split(File::PATH_SEPARATOR)
cpath += Java::java.lang.System.getProperty('sun.boot.class.path').split(File::PATH_SEPARATOR)
jruby_cpath = cpath.compact.join(File::PATH_SEPARATOR)
rescue => e
end
@@ -1,4 +1,4 @@
require_relative 'lib/concurrent/version'
require File.join(File.dirname(__FILE__ ), 'lib/concurrent/version')
Gem::Specification.new do |s|
git_files = `git ls-files`.split("\n")
@@ -22,7 +22,7 @@ be obeyed though. Features developed in `concurrent-ruby-edge` are expected to m
Please see http://concurrent-ruby.com for more information.
TXT
s.required_ruby_version = '>= 2.0.0'
s.required_ruby_version = '>= 1.9.3'
s.add_runtime_dependency 'concurrent-ruby', "~> #{Concurrent::VERSION}"
end
@@ -1,4 +1,4 @@
require_relative 'lib/concurrent/version'
require File.join(File.dirname(__FILE__ ), 'lib/concurrent/version')
Gem::Specification.new do |s|
s.name = 'concurrent-ruby-ext'
@@ -21,7 +21,7 @@ Gem::Specification.new do |s|
s.require_paths = ['lib']
s.extensions = 'ext/concurrent-ruby-ext/extconf.rb'
s.required_ruby_version = '>= 2.0.0'
s.required_ruby_version = '>= 1.9.3'
s.add_runtime_dependency 'concurrent-ruby', "= #{Concurrent::VERSION}"
end
View
@@ -1,5 +1,5 @@
require_relative 'lib/concurrent/version'
require_relative 'lib/concurrent/utility/engine'
require File.join(File.dirname(__FILE__ ), 'lib/concurrent/version')
require File.join(File.dirname(__FILE__ ), 'lib/concurrent/utility/engine')
Gem::Specification.new do |s|
git_files = `git ls-files`.split("\n")
@@ -25,5 +25,5 @@ Gem::Specification.new do |s|
Inspired by Erlang, Clojure, Go, JavaScript, actors, and classic concurrency patterns.
TXT
s.required_ruby_version = '>= 2.0.0'
s.required_ruby_version = '>= 1.9.3'
end
View
@@ -3,5 +3,5 @@
Pick a version:
* [master](./master/index.html)
* [1.1.0](./1.1.0/index.html)
* [1.1.1](./1.1.1/index.html)
* [1.0.5](./1.0.5/index.html)
@@ -343,8 +343,14 @@ <h3>Edge Features</h3>
<h2>Supported Ruby versions</h2>
<p>MRI 2.0 and above, JRuby 9000, TruffleRuby are supported.
This gem should be fully compatible with any interpreter that is compliant with Ruby 2.0 or newer.
<ul>
<li>MRI 2.0 and above</li>
<li>JRuby 9000</li>
<li>TruffleRuby are supported. </li>
<li>Any Ruby interpreter that is compliant with Ruby 2.0 or newer.</li>
</ul>
<p>Actually we still support mri 1.9.3 and jruby 1.7.27 but we are looking at ways how to drop the support.
Java 8 is preferred for JRuby but every Java version on which JRuby 9000 runs is supported.</p>
<p>The legacy support for Rubinius is kept but it is no longer maintained, if you would like to help
@@ -653,12 +659,12 @@ <h2>
<dt id="VERSION-constant" class="">VERSION =
</dt>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>1.1.0</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>1.1.1</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dt id="EDGE_VERSION-constant" class="">EDGE_VERSION =
</dt>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>0.4.0</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>0.4.1</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dt id="NULL_LOGGER-constant" class="">NULL_LOGGER =
<div class="docstring">
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
@@ -59,6 +59,18 @@
<div id="content"><div id='filecontents'><h2>Current</h2>
<h2>Release v1.1.1, edge v0.4.1 (1 Nov 2018)</h2>
<ul>
<li>(#768) add support for 1.9.3 back </li>
</ul>
<h2>Release v1.1.0, edge v0.4.0 (31 OCt 2018) (yanked)</h2>
<ul>
<li>(#768) yanked because of issues with removed 1.9.3 support </li>
</ul>
<h2>Release v1.1.0.pre2, edge v0.4.0.pre2 (18 Sep 2018)</h2>
<p>concurrent-ruby:</p>
@@ -80,6 +92,7 @@ <h2>Release v1.1.0.pre1, edge v0.4.0.pre1 (15 Aug 2018)</h2>
<p>concurrent-ruby:</p>
<ul>
<li>requires at least Ruby 2.0</li>
<li><a href="http://ruby-concurrency.github.io/concurrent-ruby/1.1.0/Concurrent/Promises.html">Promises</a>
are moved from <code>concurrent-ruby-edge</code> to <code>concurrent-ruby</code></li>
<li>Add support for TruffleRuby
File renamed without changes.
@@ -313,8 +313,14 @@ <h3>Edge Features</h3>
<h2>Supported Ruby versions</h2>
<p>MRI 2.0 and above, JRuby 9000, TruffleRuby are supported.
This gem should be fully compatible with any interpreter that is compliant with Ruby 2.0 or newer.
<ul>
<li>MRI 2.0 and above</li>
<li>JRuby 9000</li>
<li>TruffleRuby are supported. </li>
<li>Any Ruby interpreter that is compliant with Ruby 2.0 or newer.</li>
</ul>
<p>Actually we still support mri 1.9.3 and jruby 1.7.27 but we are looking at ways how to drop the support.
Java 8 is preferred for JRuby but every Java version on which JRuby 9000 runs is supported.</p>
<p>The legacy support for Rubinius is kept but it is no longer maintained, if you would like to help
File renamed without changes.
File renamed without changes.
@@ -313,8 +313,14 @@ <h3>Edge Features</h3>
<h2>Supported Ruby versions</h2>
<p>MRI 2.0 and above, JRuby 9000, TruffleRuby are supported.
This gem should be fully compatible with any interpreter that is compliant with Ruby 2.0 or newer.
<ul>
<li>MRI 2.0 and above</li>
<li>JRuby 9000</li>
<li>TruffleRuby are supported. </li>
<li>Any Ruby interpreter that is compliant with Ruby 2.0 or newer.</li>
</ul>
<p>Actually we still support mri 1.9.3 and jruby 1.7.27 but we are looking at ways how to drop the support.
Java 8 is preferred for JRuby but every Java version on which JRuby 9000 runs is supported.</p>
<p>The legacy support for Rubinius is kept but it is no longer maintained, if you would like to help
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
@@ -343,8 +343,14 @@ <h3>Edge Features</h3>
<h2>Supported Ruby versions</h2>
<p>MRI 2.0 and above, JRuby 9000, TruffleRuby are supported.
This gem should be fully compatible with any interpreter that is compliant with Ruby 2.0 or newer.
<ul>
<li>MRI 2.0 and above</li>
<li>JRuby 9000</li>
<li>TruffleRuby are supported. </li>
<li>Any Ruby interpreter that is compliant with Ruby 2.0 or newer.</li>
</ul>
<p>Actually we still support mri 1.9.3 and jruby 1.7.27 but we are looking at ways how to drop the support.
Java 8 is preferred for JRuby but every Java version on which JRuby 9000 runs is supported.</p>
<p>The legacy support for Rubinius is kept but it is no longer maintained, if you would like to help
@@ -653,12 +659,12 @@ <h2>
<dt id="VERSION-constant" class="">VERSION =
</dt>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>1.1.0</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>1.1.1</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dt id="EDGE_VERSION-constant" class="">EDGE_VERSION =
</dt>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>0.4.0</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dd><pre class="code"><span class='tstring'><span class='tstring_beg'>&#39;</span><span class='tstring_content'>0.4.1</span><span class='tstring_end'>&#39;</span></span></pre></dd>
<dt id="NULL_LOGGER-constant" class="">NULL_LOGGER =
<div class="docstring">
@@ -59,6 +59,18 @@
<div id="content"><div id='filecontents'><h2>Current</h2>
<h2>Release v1.1.1, edge v0.4.1 (1 Nov 2018)</h2>
<ul>
<li>(#768) add support for 1.9.3 back </li>
</ul>
<h2>Release v1.1.0, edge v0.4.0 (31 OCt 2018) (yanked)</h2>
<ul>
<li>(#768) yanked because of issues with removed 1.9.3 support </li>
</ul>
<h2>Release v1.1.0.pre2, edge v0.4.0.pre2 (18 Sep 2018)</h2>
<p>concurrent-ruby:</p>
@@ -80,6 +92,7 @@ <h2>Release v1.1.0.pre1, edge v0.4.0.pre1 (15 Aug 2018)</h2>
<p>concurrent-ruby:</p>
<ul>
<li>requires at least Ruby 2.0</li>
<li><a href="http://ruby-concurrency.github.io/concurrent-ruby/1.1.0/Concurrent/Promises.html">Promises</a>
are moved from <code>concurrent-ruby-edge</code> to <code>concurrent-ruby</code></li>
<li>Add support for TruffleRuby
@@ -313,8 +313,14 @@ <h3>Edge Features</h3>
<h2>Supported Ruby versions</h2>
<p>MRI 2.0 and above, JRuby 9000, TruffleRuby are supported.
This gem should be fully compatible with any interpreter that is compliant with Ruby 2.0 or newer.
<ul>
<li>MRI 2.0 and above</li>
<li>JRuby 9000</li>
<li>TruffleRuby are supported. </li>
<li>Any Ruby interpreter that is compliant with Ruby 2.0 or newer.</li>
</ul>
<p>Actually we still support mri 1.9.3 and jruby 1.7.27 but we are looking at ways how to drop the support.
Java 8 is preferred for JRuby but every Java version on which JRuby 9000 runs is supported.</p>
<p>The legacy support for Rubinius is kept but it is no longer maintained, if you would like to help
Oops, something went wrong.

0 comments on commit 3b3f9bf

Please sign in to comment.