Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Fetching contributors…
Cannot retrieve contributors at this time
67 lines (54 sloc) 1.7 KB
Ruby-GNOME2 -- Ruby bindings for GNOME-2.0
This is a set of bindings for the GNOME-2.0 libraries for use from Ruby.
To use them, you will need Ruby-1.6 and glib-2.0.0, gtk+-2.0.0, pango-1.1.0,
gconf2-1.2.0, libgnome-2.0.0, libart_lgpl-2.3.0, libgnomecanvas-2.0.0,
libgnomeui-2.0.0, libglade-2.0.0 or later installed on your system.
Keep in mind that you will need both the runtime libraries and the header
files installed.
Release packages
- Ruby/GLib2
- Ruby/GdkPixbuf2
- Ruby/Pango
- Ruby/GTK2
- ruby-gtk2
- Ruby/GNOME2
- Ruby/GnomeCanvas2
- Ruby/Libart2
- Ruby/Libglade2
- Ruby/GConf2
1. ruby extconf.rb
2. make
3. su
4. make install
To compile and install a particular sub-binding, you should run:
0. cd <each sub-directory>
1. ruby extconf.rb
2. make
3. su
4. make install
You should install a sub-binding with its dependencies.
The current dependencies are:
Ruby/GTK depends on Ruby/GLib, Ruby/GdkPixbuf, Ruby/Pango.
Ruby/GdkPixbuf depends on Ruby/GTK.
Ruby/GNOME depends on Ruby/GTK.
Ruby/GnomeCanvas depends on Ruby/GTK.
Ruby/Libart none.
Ruby/Libglade depends on Ruby/GTK, Ruby/GNOME(optional).
Ruby/GConf depends on Ruby/GLib.
Copyright (c) 2002,2003 The Ruby-GNOME2 Project Team
This program is free software.
You can distribute/modify this program under the terms of
the GNU LIBRARY General Public License version 2.
Project Website
Jump to Line
Something went wrong with that request. Please try again.