New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

poppler: runtime dependencies are not updated for gi? #1107

Closed
obache opened this Issue Oct 22, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@obache

obache commented Oct 22, 2017

In 3.1.9 (Migrated to GObject Introspection bindings), poppler still require cairo>=1.14.0 and gdk_pixbuf2 gem:

package.dependency.gem.runtime = [["cairo", ">= 1.14.0"], "gdk_pixbuf2"]

But poppler/lib/poppler.rb require gobject-introspection, gio2 and cairo-gobject:

require "gobject-introspection"
require "gio2"
require "cairo-gobject"

package.windows and package.external_packages also should be adjusted.

@kou

This comment has been minimized.

Show comment
Hide comment
@kou

kou Oct 27, 2017

Member

Thanks. I've updated.

Member

kou commented Oct 27, 2017

Thanks. I've updated.

@kou kou closed this in 5c83cb7 Oct 27, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment