Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Renamed the gemspec back to the proper name while preserving Bundler …

…compatibility with a symlink.

(Will need to submit a patch to Bundler to have it correctly recognize .gemspec files.)
  • Loading branch information...
commit d1ed82a241b6e46f199497632ac71d0936a0bef0 1 parent 00c1095
@bendiken bendiken authored
Showing with 36 additions and 35 deletions.
  1. +35 −0 .gemspec
  2. +0 −35 rdf.gemspec
  3. +1 −0  rdf.gemspec
View
35 .gemspec
@@ -0,0 +1,35 @@
+#!/usr/bin/env ruby -rubygems
+# -*- encoding: utf-8 -*-
+
+GEMSPEC = Gem::Specification.new do |gem|
+ gem.version = File.read('VERSION').chomp
+ gem.date = File.mtime('VERSION').strftime('%Y-%m-%d')
+
+ gem.name = 'rdf'
+ gem.homepage = 'http://rdf.rubyforge.org/'
+ gem.license = 'Public Domain' if gem.respond_to?(:license=)
+ gem.summary = 'A Ruby library for working with Resource Description Framework (RDF) data.'
+ gem.description = 'RDF.rb is a pure-Ruby library for working with Resource Description Framework (RDF) data.'
+ gem.rubyforge_project = 'rdf'
+
+ gem.authors = ['Arto Bendiken', 'Ben Lavender', 'Gregg Kellogg']
+ gem.email = 'public-rdf-ruby@w3.org'
+
+ gem.platform = Gem::Platform::RUBY
+ gem.files = %w(AUTHORS CREDITS README UNLICENSE VERSION bin/rdf etc/doap.nt) + Dir.glob('lib/**/*.rb')
+ gem.bindir = %q(bin)
+ gem.executables = %w(rdf)
+ gem.default_executable = gem.executables.first
+ gem.require_paths = %w(lib)
+ gem.extensions = %w()
+ gem.test_files = %w()
+ gem.has_rdoc = false
+
+ gem.required_ruby_version = '>= 1.8.1'
+ gem.requirements = []
+ gem.add_runtime_dependency 'addressable', '>= 2.2'
+ gem.add_development_dependency 'yard', '>= 0.6.0'
+ gem.add_development_dependency 'rspec', '>= 1.3.0'
+ gem.add_development_dependency 'rdf-spec', '~> 0.2.3'
+ gem.post_install_message = nil
+end
View
35 rdf.gemspec
@@ -1,35 +0,0 @@
-#!/usr/bin/env ruby -rubygems
-# -*- encoding: utf-8 -*-
-
-GEMSPEC = Gem::Specification.new do |gem|
- gem.version = File.read('VERSION').chomp
- gem.date = File.mtime('VERSION').strftime('%Y-%m-%d')
-
- gem.name = 'rdf'
- gem.homepage = 'http://rdf.rubyforge.org/'
- gem.license = 'Public Domain' if gem.respond_to?(:license=)
- gem.summary = 'A Ruby library for working with Resource Description Framework (RDF) data.'
- gem.description = 'RDF.rb is a pure-Ruby library for working with Resource Description Framework (RDF) data.'
- gem.rubyforge_project = 'rdf'
-
- gem.authors = ['Arto Bendiken', 'Ben Lavender', 'Gregg Kellogg']
- gem.email = 'public-rdf-ruby@w3.org'
-
- gem.platform = Gem::Platform::RUBY
- gem.files = %w(AUTHORS CREDITS README UNLICENSE VERSION bin/rdf etc/doap.nt) + Dir.glob('lib/**/*.rb')
- gem.bindir = %q(bin)
- gem.executables = %w(rdf)
- gem.default_executable = gem.executables.first
- gem.require_paths = %w(lib)
- gem.extensions = %w()
- gem.test_files = %w()
- gem.has_rdoc = false
-
- gem.required_ruby_version = '>= 1.8.1'
- gem.requirements = []
- gem.add_runtime_dependency 'addressable', '>= 2.2'
- gem.add_development_dependency 'yard', '>= 0.6.0'
- gem.add_development_dependency 'rspec', '>= 1.3.0'
- gem.add_development_dependency 'rdf-spec', '~> 0.2.3'
- gem.post_install_message = nil
-end
View
1  rdf.gemspec
Please sign in to comment.
Something went wrong with that request. Please try again.