Skip to content
Browse files

Fixed 1.8.7 compatibility issues in rdf/cli and bin/rdf.

  • Loading branch information...
1 parent 90381a7 commit ebf83b400f68811784c87b6f8f5cce8872a88a9f @gkellogg gkellogg committed
Showing with 4 additions and 1 deletion.
  1. +1 −0 bin/rdf
  2. +3 −1 lib/rdf/cli.rb
View
1 bin/rdf
@@ -1,5 +1,6 @@
#!/usr/bin/env ruby
$:.unshift(File.expand_path(File.join(File.dirname(__FILE__), '..', 'lib')))
+require 'rubygems'
require 'rdf/cli'
options = RDF::CLI.options do
View
4 lib/rdf/cli.rb
@@ -1,9 +1,11 @@
require 'rdf'
+require 'rdf/ntriples'
+require 'rdf/nquads'
require 'optparse'
begin
gem 'linkeddata'
require 'linkeddata'
-rescue
+rescue LoadError
# Silently load without linkeddata
end

0 comments on commit ebf83b4

Please sign in to comment.
Something went wrong with that request. Please try again.