Permalink
Browse files

no need to supply jruby itself to the classpath

  • Loading branch information...
1 parent d8440cc commit 291f74b4ecc554f3faeee62a2d06b2c315822759 @mkristian mkristian committed May 28, 2015
Showing with 4 additions and 3 deletions.
  1. +1 −0 .gitignore
  2. +0 −2 Mavenfile
  3. +3 −1 Rakefile
View
@@ -2,5 +2,6 @@
*.bundle
*.jar
*.class
+.mvn
/pkg
/tmp
View
@@ -1,7 +1,5 @@
#-*- mode: ruby -*-
-pom 'org.jruby:jruby:${jruby.version}', :scope => :provided
-
jar 'org.yaml:snakeyaml:${snakeyaml.version}'
plugin :dependency, '2.8', :outputFile => 'pkg/classpath'
View
@@ -50,7 +50,9 @@ $hoe = Hoe.spec 'psych' do
require 'maven/ruby/maven'
# uses Mavenfile to write classpath into pkg/classpath
# and tell maven via system properties the snakeyaml version
- Maven::Ruby::Maven.new.exec( 'dependency:build-classpath', "-Djruby.version=#{JRUBY_VERSION}", "-Dsnakeyaml.version=#{Psych::DEFAULT_SNAKEYAML_VERSION}")#, '--quiet' )
+ # this is basically the same as running from the commandline:
+ # rmvn dependency:build-classpath -Dsnakeyaml.version='use version from Psych::DEFAULT_SNAKEYAML_VERSION here'
+ Maven::Ruby::Maven.new.exec( 'dependency:build-classpath', "-Dsnakeyaml.version=#{Psych::DEFAULT_SNAKEYAML_VERSION}", '-Dverbose=true')#, '--quiet' )
ext.source_version = '1.7'
ext.target_version = '1.7'
ext.classpath = File.read('pkg/classpath')

0 comments on commit 291f74b

Please sign in to comment.