Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Drop old ruby versions which are no longer tested #325

Merged
merged 2 commits into from Sep 2, 2019

Conversation

nobu
Copy link
Member

@nobu nobu commented Aug 31, 2019

It doesn't seem working with ruby 2.1 already.

$ ruby2.1 -I./lib exe/rake 
/opt/local/bin/ruby2.1 -w -I"lib:test"  "/Users/nobu/src/ruby/rake/lib/rake/rake_test_loader.rb" "test/test_private_reader.rb" "test/test_rake.rb" "test/test_rake_application.rb" "test/test_rake_application_options.rb" "test/test_rake_backtrace.rb" "test/test_rake_clean.rb" "test/test_rake_cpu_counter.rb" "test/test_rake_definitions.rb" "test/test_rake_directory_task.rb" "test/test_rake_dsl.rb" "test/test_rake_early_time.rb" "test/test_rake_extension.rb" "test/test_rake_file_creation_task.rb" "test/test_rake_file_list.rb" "test/test_rake_file_list_path_map.rb" "test/test_rake_file_task.rb" "test/test_rake_file_utils.rb" "test/test_rake_functional.rb" "test/test_rake_invocation_chain.rb" "test/test_rake_late_time.rb" "test/test_rake_linked_list.rb" "test/test_rake_makefile_loader.rb" "test/test_rake_multi_task.rb" "test/test_rake_name_space.rb" "test/test_rake_package_task.rb" "test/test_rake_path_map.rb" "test/test_rake_path_map_explode.rb" "test/test_rake_path_map_partial.rb" "test/test_rake_pseudo_status.rb" "test/test_rake_rake_test_loader.rb" "test/test_rake_reduce_compat.rb" "test/test_rake_require.rb" "test/test_rake_rules.rb" "test/test_rake_scope.rb" "test/test_rake_task.rb" "test/test_rake_task_argument_parsing.rb" "test/test_rake_task_arguments.rb" "test/test_rake_task_manager.rb" "test/test_rake_task_manager_argument_resolution.rb" "test/test_rake_task_with_arguments.rb" "test/test_rake_test_task.rb" "test/test_rake_thread_pool.rb" "test/test_rake_top_level_functions.rb" "test/test_rake_win32.rb" "test/test_thread_history_display.rb" "test/test_trace_output.rb" 
/opt/local/lib/ruby2.1/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'minitest' (~> 5) - did find: [minitest-4.7.5] (Gem::LoadError)
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/dependency.rb:309:in `to_spec'
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/core_ext/kernel_gem.rb:53:in `gem'
	from /Users/nobu/src/ruby/rake/test/helper.rb:13:in `<top (required)>'
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/core_ext/kernel_require.rb:135:in `require'
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/core_ext/kernel_require.rb:135:in `rescue in require'
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/core_ext/kernel_require.rb:144:in `require'
	from /Users/nobu/src/ruby/rake/test/test_private_reader.rb:2:in `<top (required)>'
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/core_ext/kernel_require.rb:135:in `require'
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/core_ext/kernel_require.rb:135:in `rescue in require'
	from /opt/local/lib/ruby2.1/2.1.0/rubygems/core_ext/kernel_require.rb:144:in `require'
	from /Users/nobu/src/ruby/rake/lib/rake/rake_test_loader.rb:17:in `block in <main>'
	from /Users/nobu/src/ruby/rake/lib/rake/rake_test_loader.rb:5:in `select'
	from /Users/nobu/src/ruby/rake/lib/rake/rake_test_loader.rb:5:in `<main>'
rake aborted!
Command failed with status (1): [ruby -w -I"lib:test"  "/Users/nobu/src/ruby/rake/lib/rake/rake_test_loader.rb" "test/test_private_reader.rb" "test/test_rake.rb" "test/test_rake_application.rb" "test/test_rake_application_options.rb" "test/test_rake_backtrace.rb" "test/test_rake_clean.rb" "test/test_rake_cpu_counter.rb" "test/test_rake_definitions.rb" "test/test_rake_directory_task.rb" "test/test_rake_dsl.rb" "test/test_rake_early_time.rb" "test/test_rake_extension.rb" "test/test_rake_file_creation_task.rb" "test/test_rake_file_list.rb" "test/test_rake_file_list_path_map.rb" "test/test_rake_file_task.rb" "test/test_rake_file_utils.rb" "test/test_rake_functional.rb" "test/test_rake_invocation_chain.rb" "test/test_rake_late_time.rb" "test/test_rake_linked_list.rb" "test/test_rake_makefile_loader.rb" "test/test_rake_multi_task.rb" "test/test_rake_name_space.rb" "test/test_rake_package_task.rb" "test/test_rake_path_map.rb" "test/test_rake_path_map_explode.rb" "test/test_rake_path_map_partial.rb" "test/test_rake_pseudo_status.rb" "test/test_rake_rake_test_loader.rb" "test/test_rake_reduce_compat.rb" "test/test_rake_require.rb" "test/test_rake_rules.rb" "test/test_rake_scope.rb" "test/test_rake_task.rb" "test/test_rake_task_argument_parsing.rb" "test/test_rake_task_arguments.rb" "test/test_rake_task_manager.rb" "test/test_rake_task_manager_argument_resolution.rb" "test/test_rake_task_with_arguments.rb" "test/test_rake_test_task.rb" "test/test_rake_thread_pool.rb" "test/test_rake_top_level_functions.rb" "test/test_rake_win32.rb" "test/test_thread_history_display.rb" "test/test_trace_output.rb" ]
exe/rake:27:in `<main>'
Tasks: TOP => default => test
(See full trace by running task with --trace)

@hsbt hsbt merged commit d10b19e into ruby:master Sep 2, 2019
1 check passed
yahonda added a commit to yahonda/google-cloud-ruby that referenced this issue Mar 3, 2020
Related to googleapis#4884

To prepare Ruby 3 keyword arguments support, there are some other gems also need update. `rake` is one of them.

* Rake 13.0.0 supports Ruby 3 keyword arguments by ruby/rake#326
* Rake 13 drops Ruby 2.1 or older support by ruby/rake#325
* Gems under `google-cloud-ruby` repository only supports Ruby 2.4 or higher then dropping Ruby 2.1 support should not be an issue.

I have bumped all of Rake under `google-cloud-ruby` repository.
quartzmo added a commit to googleapis/google-cloud-ruby that referenced this issue Mar 4, 2020
To prepare Ruby 3 keyword arguments support, there are some other gems also need update. `rake` is one of them.

* Rake 13.0.0 supports Ruby 3 keyword arguments by ruby/rake#326
* Rake 13 drops Ruby 2.1 or older support by ruby/rake#325
* Gems under `google-cloud-ruby` repository only supports Ruby 2.4 or higher then dropping Ruby 2.1 support should not be an issue.

refs: #4884
pr: #4897
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants