Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix broken links to assets. Fixes #359. #360

Merged
merged 2 commits into from Mar 23, 2016
Merged

Fix broken links to assets. Fixes #359. #360

merged 2 commits into from Mar 23, 2016

Conversation

awood
Copy link
Contributor

@awood awood commented Aug 3, 2015

No description provided.

@awood
Copy link
Contributor Author

awood commented Aug 3, 2015

This patch isn't 100% perfect: the CSS is still missing when the request 404s. generate_servlet_not_found method in generator.rb isn't setting the rel_prefix but I'm not familiar enough with the code-base to say whether it should be or whether a 404 requires some other special handling.

@awood
Copy link
Contributor Author

awood commented Aug 17, 2015

The test failure is in TestRDocMarkupToHtml#test_parseable_eh against Ruby HEAD. This PR doesn't touch any code related to that, so in my opinion the failure is a false positive.

@awood
Copy link
Contributor Author

awood commented Oct 2, 2015

Anyone have any comments on this? I'd love to see it make it into an upcoming release.

@zzak
Copy link
Member

zzak commented Dec 22, 2015

I'm not sure about the js and font changes though

@awood
Copy link
Contributor Author

awood commented Feb 24, 2016

@zzak I'm a little unclear about your last comment. Is there something I should address in the PR or is it more of a general "I want someone else to look at this too"?

@zzak
Copy link
Member

zzak commented Mar 23, 2016

@awood I tested out, and seems like everything is working!

Thank you! <3 <3

@zzak zzak merged commit deb68c8 into ruby:master Mar 23, 2016
zzak added a commit that referenced this pull request Mar 23, 2016
@awood
Copy link
Contributor Author

awood commented Mar 23, 2016

😺 💎 💰

@MarioRuiz
Copy link

when is this fixed gonna be released? no new releases since february and this bug is not very nice to show when running a gem server on Ruby 2.2.4 "GET /doc_root/css/fonts.css HTTP/1.1" 404 2048
so any idea?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants