Permalink
Browse files

fix running db problem running specs under jruby

  • Loading branch information...
1 parent c28832f commit 3647b57a3ead65809352d87117c743a8fe803e2e @soupmatt soupmatt committed Mar 18, 2013
Showing with 6 additions and 11 deletions.
  1. +0 −9 Gemfile
  2. +5 −1 rubycas-client.gemspec
  3. +1 −1 spec/spec_helper.rb
View
@@ -10,13 +10,4 @@ group :tools do
gem "fuubar"
gem "rb-fsevent"
gem "growl", :group => :darwin
-
- platforms :ruby do
- gem "sqlite3"
- end
-
- platforms :jruby do
- gem "jruby-openssl"
- gem "activerecord-jdbcsqlite3-adapter"
- end
end
@@ -30,5 +30,9 @@ Gem::Specification.new do |gem|
gem.add_development_dependency("appraisal")
gem.add_development_dependency("rails")
gem.add_development_dependency("simplecov")
- gem.add_development_dependency("sqlite3")
+ if defined?(JRUBY_VERSION)
+ gem.add_development_dependency("activerecord-jdbcsqlite3-adapter")
+ else
+ gem.add_development_dependency("sqlite3")
+ end
end
View
@@ -1,6 +1,6 @@
require 'bundler'
Bundler.setup(:default, :development)
-require 'simplecov' unless ENV['TRAVIS']
+require 'simplecov' unless ENV['TRAVIS'] || defined?(JRUBY_VERSION)
Bundler.require
require 'rubycas-client'

0 comments on commit 3647b57

Please sign in to comment.