Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 77 lines (67 sloc) 1.584 kb
da23fdb Erik Michaels-Ober Use HTTPS rubygems source
sferik authored
1 source 'https://rubygems.org'
15232c7 Evan Phoenix Remove ruby in Gemfile
evanphx authored
2 # ruby '1.9.3'
69689e8 Nick Quaranto Making bundler a little happier
qrush authored
3
01bab26 Erik Michaels-Ober Update rails to version 3.2.17
sferik authored
4 gem 'rails', '~> 3.2.17'
1427175 Erik Michaels-Ober Update rails, mail, and all sub-dependencies
sferik authored
5
52b5833 Erik Michaels-Ober Update fog dependency to version 1.6.0
sferik authored
6 gem 'builder'
d398c3d Nick Quaranto bump to Rails 3.2!
qrush authored
7 gem 'dynamic_form'
a764ce5 Erik Michaels-Ober Update excon dependency to version 0.16.7
sferik authored
8 gem 'excon'
22baafd Evan Phoenix Downgrade fog and excon to fix S3 communication issues
evanphx authored
9 gem 'fog', '= 1.15.0'
4d9db7b Nick Rivadeneira Move to capybara/cucumber 1.0
nickrivadeneira authored
10 gem 'gchartrb', :require => 'google_chart'
0630956 Erik Michaels-Ober Update gravtastic dependency to version 3.1.0
sferik authored
11 gem 'gravtastic'
92a050f Erik Michaels-Ober Update high_voltage dependency to version 1.0.0
sferik authored
12 gem 'high_voltage'
c7f708f Nick Quaranto add highline to the main gem group
qrush authored
13 gem 'highline'
07bff51 Erik Michaels-Ober Update guard-cucumber dependency to version 0.7.2
sferik authored
14 gem 'jquery-rails'
6b265d5 Erik Michaels-Ober Add librato for ActiveSupport::Notifications performance trends
sferik authored
15 gem 'librato-rails'
5710d7e Erik Michaels-Ober Don't specify mail version in the Gemfile
sferik authored
16 gem 'mail'
4c850e9 Daniel Huckstep Replace memcached with dalli
darkhelmet authored
17 gem 'dalli'
e06338a Erik Michaels-Ober Add explicit mutli_json dependency
sferik authored
18 gem 'multi_json'
3290904 Erik Michaels-Ober Update paul_revere dependency to version 0.2.0
sferik authored
19 gem 'paul_revere'
86fa58a Erik Michaels-Ober Begin updating gem dependencies
sferik authored
20 gem 'pg'
94c39cd Evan Phoenix Begin work for standalone api server
evanphx authored
21 gem 'puma'
6fb0cc2 Erik Michaels-Ober Revert "Downgrade rack to see if that's what's causing the maintenance i...
sferik authored
22 gem 'rack'
08a683e Erik Michaels-Ober Update rack dependency to version 1.2.3
sferik authored
23 gem 'rack-maintenance', :require => 'rack/maintenance'
60243e5 Erik Michaels-Ober Add explicit rdoc dependency for simple_markup
sferik authored
24 gem 'rdoc'
a3acb17 Erik Michaels-Ober Update redis dependency to version 2.2.1
sferik authored
25 gem 'redis'
4d9db7b Nick Rivadeneira Move to capybara/cucumber 1.0
nickrivadeneira authored
26 gem 'rest-client', :require => 'rest_client'
899feb6 Erik Michaels-Ober Remove remaining (non-prerelease) version numbers from Gemfile.
sferik authored
27 gem 'sinatra'
03a274b Evan Phoenix Add unicorn to Gemfile to begin moving to new setup
evanphx authored
28 gem 'unicorn'
52b5833 Erik Michaels-Ober Update fog dependency to version 1.6.0
sferik authored
29 gem 'validates_formatting_of'
3fa4498 Erik Michaels-Ober Update will_paginate dependency to version 3.0.0
sferik authored
30 gem 'will_paginate'
69d8efe Erik Michaels-Ober Update xml-simple dependency to version 1.1.0
sferik authored
31 gem 'xml-simple'
1733fcd Nick Quaranto go back to yajl since oj isn't compiling
qrush authored
32 gem 'yajl-ruby', :require => 'yajl'
3370b09 Nick Quaranto Bundle this up
qrush authored
33
d398c3d Nick Quaranto bump to Rails 3.2!
qrush authored
34 # enable if on heroku, make sure to toss this into an initializer:
35 # Rails.application.config.middleware.use HerokuAssetCacher
36 #gem 'heroku_asset_cacher', :git => "git@github.com/qrush/heroku_asset_cacher"
37
14f2ba5 Erik Michaels-Ober Add entity-relationship diagram
sferik authored
38 group :development do
c35a0af David Radcliffe deploy via capistrano!
dwradcliffe authored
39 gem 'capistrano', '~> 2.0'
14f2ba5 Erik Michaels-Ober Add entity-relationship diagram
sferik authored
40 gem 'rails-erd'
1540a53 Erik Michaels-Ober Add pry as a development dependency
sferik authored
41 gem 'pry'
14f2ba5 Erik Michaels-Ober Add entity-relationship diagram
sferik authored
42 end
43
78f4c37 Nick Quaranto Moving to bundler 0.9
qrush authored
44 group :test do
38eacbe Erik Michaels-Ober Update capybara dependency to version 2.0.2
sferik authored
45 gem 'capybara'
a4112e3 Erik Michaels-Ober Fix cucumber-rails warning
sferik authored
46 gem 'cucumber-rails', :require => false
9a0abf0 Erik Michaels-Ober Update database_cleaner dependency to version 0.6.7
sferik authored
47 gem 'database_cleaner'
dadcd99 Erik Michaels-Ober Upgrade factory_girl_rails dependency to version 4.0.0
sferik authored
48 gem 'factory_girl_rails'
928b5c7 Erik Michaels-Ober Update launchy dependency to version 0.4.0
sferik authored
49 gem 'launchy'
86fa58a Erik Michaels-Ober Begin updating gem dependencies
sferik authored
50 gem 'nokogiri'
4d9db7b Nick Rivadeneira Move to capybara/cucumber 1.0
nickrivadeneira authored
51 gem 'rack-test', :require => 'rack/test'
2872b3a Erik Michaels-Ober Update rr dependency to version 1.0.2
sferik authored
52 gem 'rr'
b15bb01 Christopher Meiklejohn Don't require test/unit too early.
cmeiklejohn authored
53 gem 'shoulda', :require => false
899feb6 Erik Michaels-Ober Remove remaining (non-prerelease) version numbers from Gemfile.
sferik authored
54 gem 'timecop'
48cbd69 Erik Michaels-Ober Update webmock dependency to version 1.6.4
sferik authored
55 gem 'webmock'
6bb9d32 Get gemcutter running on the bundler
Carl Lerche authored
56 end
c61c40d Erik Michaels-Ober Try removing explicit yaml requires to fix syck bug
sferik authored
57
b66eff4 Erik Michaels-Ober Apparently validates_formatting_of is also bad
sferik authored
58 # For some reason, including these gems in the maintenance environment enables
d81d7a8 Erik Michaels-Ober For some reason, including this gem in the maintenance environment enabl...
sferik authored
59 # maintenance mode
60 group :development, :test, :staging, :production do
9272def Erik Michaels-Ober Update clearance dependency to version 1.1.0
sferik authored
61 gem 'clearance', '~> 1.1'
fb80f2f Erik Michaels-Ober Move daemons into purgatory
sferik authored
62 gem 'daemons'
e54cbc2 Erik Michaels-Ober Update delayed_job dependency to version 3.0.4
sferik authored
63 gem 'delayed_job'
d81d7a8 Erik Michaels-Ober For some reason, including this gem in the maintenance environment enabl...
sferik authored
64 gem 'delayed_job_active_record'
627fd62 Nick Quaranto add rpm contrib, move newrelic related gems to be disabled in maintenanc...
qrush authored
65
66 gem 'newrelic_rpm'
7ba2760 Evan Phoenix Switch to newrelic-redis gem rather than rpm_contrib
evanphx authored
67 gem 'newrelic-redis'
d81d7a8 Erik Michaels-Ober For some reason, including this gem in the maintenance environment enabl...
sferik authored
68 end
69
4c8d57f Nick Quaranto add a recovery mode that will allow the site to continue operating witho...
qrush authored
70 group :recovery do
71 gem "fakeredis"
72 end
73
c61c40d Erik Michaels-Ober Try removing explicit yaml requires to fix syck bug
sferik authored
74 platforms :jruby do
75 gem 'jruby-openssl'
76 end
Something went wrong with that request. Please try again.