Skip to content
Newer
Older
100644 77 lines (69 sloc) 1.73 KB
d496620 @sferik Use HTTPS rubygems source
sferik authored Dec 12, 2011
1 source 'https://rubygems.org'
c138cfb @qrush Making bundler a little happier
qrush authored Oct 9, 2009
2
41be304 @nateberkopec Free up ~22MB of process memory used by mime-types gem
nateberkopec authored Jan 12, 2016
3 # https://github.com/mime-types/ruby-mime-types/issues/94
4 # This can be removed once all gems depend on > 3.0
0f25c10 @arthurnn Bump mime-types gem
arthurnn authored Feb 17, 2016
5 gem 'mime-types', '~> 2.99', require: 'mime/types/columnar'
41be304 @nateberkopec Free up ~22MB of process memory used by mime-types gem
nateberkopec authored Jan 12, 2016
6
d2c473b @arthurnn Update rails to final version
arthurnn authored Mar 8, 2016
7 gem 'rails', '~> 4.2.6'
f9851e9 @huacnlee Add rails-i18n;
huacnlee authored Aug 27, 2015
8 gem 'rails-i18n'
a50e50c @arthurnn Bump rails to 4.2.0
arthurnn authored Feb 15, 2015
9
abfd36c @sferik Update rubocop to version 0.33.0
sferik authored Aug 22, 2015
10 gem 'autoprefixer-rails'
96e90f5 @ktheory Gemfile: Add shoryuken & aws-sdk
ktheory authored Jan 12, 2016
11 gem 'aws-sdk', '~> 2.2'
3e04a6c @sferik Update fog dependency to version 1.6.0
sferik authored Oct 17, 2012
12 gem 'builder'
abfd36c @sferik Update rubocop to version 0.33.0
sferik authored Aug 22, 2015
13 gem 'clearance'
14 gem 'clearance-deprecated_password_strategies'
15 gem 'daemons'
16 gem 'dalli'
17 gem 'delayed_job'
18 gem 'delayed_job_active_record'
7f92968 @bf4 Add doorkeepr OAuth2 Provider
bf4 authored Jul 9, 2015
19 gem 'doorkeeper'
c73e284 @qrush bump to Rails 3.2!
qrush authored Mar 24, 2012
20 gem 'dynamic_form'
0941b00 @kirs Enable assets
kirs authored Nov 25, 2014
21 gem 'gchartrb', require: 'google_chart'
76c392a @sferik Update gravtastic dependency to version 3.1.0
sferik authored Jul 15, 2011
22 gem 'gravtastic'
8d1401c @sferik Update high_voltage dependency to version 1.0.0
sferik authored Jul 15, 2011
23 gem 'high_voltage'
03b07b6 @qrush add highline to the main gem group
qrush authored Sep 6, 2012
24 gem 'highline'
a9745c2 @lucianosousa removing version constraint from honeybadger gem
lucianosousa authored Nov 29, 2015
25 gem 'honeybadger'
7f92968 @bf4 Add doorkeepr OAuth2 Provider
bf4 authored Jul 9, 2015
26 gem 'http_accept_language'
1614c4b @sferik Update guard-cucumber dependency to version 0.7.2
sferik authored Oct 1, 2011
27 gem 'jquery-rails'
3d6e2bd @sferik Don't specify mail version in the Gemfile
sferik authored Sep 3, 2011
28 gem 'mail'
9616684 @sferik Add explicit mutli_json dependency
sferik authored Oct 14, 2011
29 gem 'multi_json'
abfd36c @sferik Update rubocop to version 0.33.0
sferik authored Aug 22, 2015
30 gem 'newrelic-redis'
31 gem 'newrelic_rpm'
cf91d9c @Ch4s3 update paul revere
Ch4s3 authored Jul 17, 2015
32 gem 'paul_revere', '~> 2.0'
db05d8d @sferik Begin updating gem dependencies
sferik authored Jul 15, 2011
33 gem 'pg'
abfd36c @sferik Update rubocop to version 0.33.0
sferik authored Aug 22, 2015
34 gem 'psych', '~> 2.0.12'
af69c00 @sferik Revert "Downgrade rack to see if that's what's causing the maintenanc…
sferik authored Dec 28, 2011
35 gem 'rack'
1c2b7a3 @sferik Update rdoc to version 4.2.0
sferik authored Jul 14, 2015
36 gem 'rdoc'
e932be7 @sferik Update redis dependency to version 2.2.1
sferik authored Jul 15, 2011
37 gem 'redis'
0941b00 @kirs Enable assets
kirs authored Nov 25, 2014
38 gem 'rest-client', require: 'rest_client'
96e90f5 @ktheory Gemfile: Add shoryuken & aws-sdk
ktheory authored Jan 12, 2016
39 gem 'shoryuken', '~> 2.0.2', require: nil
3879e36 @dwradcliffe add statsd
dwradcliffe authored Jan 31, 2015
40 gem 'statsd-instrument', '~> 2.0.6'
abfd36c @sferik Update rubocop to version 0.33.0
sferik authored Aug 22, 2015
41 gem 'uglifier', '>= 1.0.3'
d899055 @evanphx Add unicorn to Gemfile to begin moving to new setup
evanphx authored Sep 23, 2012
42 gem 'unicorn'
3e04a6c @sferik Update fog dependency to version 1.6.0
sferik authored Oct 17, 2012
43 gem 'validates_formatting_of'
c4e13d3 @sferik Update will_paginate dependency to version 3.0.0
sferik authored Aug 9, 2011
44 gem 'will_paginate'
20b2d2b @dwradcliffe add elasticsearch (behind flag for testing)
dwradcliffe authored Jun 12, 2015
45 gem 'elasticsearch-model', '~> 0.1.7'
46 gem 'elasticsearch-rails', '~> 0.1.7'
0e12c31 @dwradcliffe elasticsearch dsl with suggestions
dwradcliffe authored Nov 26, 2015
47 gem 'elasticsearch-dsl', '~> 0.1.2'
d01d296 @sferik Update xml-simple dependency to version 1.1.0
sferik authored Jul 15, 2011
48 gem 'xml-simple'
0941b00 @kirs Enable assets
kirs authored Nov 25, 2014
49 gem 'yajl-ruby', require: 'yajl'
9436710 @qrush Bundle this up
qrush authored Oct 2, 2009
50
92edb9c @dwradcliffe make home page resilient to redis
dwradcliffe authored Jun 28, 2015
51 group :development, :test do
30e345e @arthurnn Require false rubocop
arthurnn authored Feb 5, 2016
52 gem 'rubocop', require: false
c2860a5 @dwradcliffe Update toxiproxy to version 0.1.3
dwradcliffe authored Jul 2, 2015
53 gem 'toxiproxy', '~> 0.1.3'
92edb9c @dwradcliffe make home page resilient to redis
dwradcliffe authored Jun 28, 2015
54 end
55
225d111 @sferik Add entity-relationship diagram
sferik authored Aug 7, 2011
56 group :development do
c3c9c7d @dwradcliffe add quiet_assets gem for development
dwradcliffe authored May 30, 2015
57 gem 'quiet_assets'
225d111 @sferik Add entity-relationship diagram
sferik authored Aug 8, 2011
58 gem 'rails-erd'
59 end
60
1651ef8 @qrush Moving to bundler 0.9
qrush authored Feb 18, 2010
61 group :test do
367e14f @arthurnn Update minitest dependency to work with rails 3 and 4
arthurnn authored Dec 24, 2014
62 gem 'minitest', require: false
2275657 @sferik Update capybara dependency to version 2.0.2
sferik authored Dec 31, 2012
63 gem 'capybara'
0902211 @sferik Upgrade factory_girl_rails dependency to version 4.0.0
sferik authored Aug 5, 2012
64 gem 'factory_girl_rails'
b353c27 @sferik Update launchy dependency to version 0.4.0
sferik authored Jul 15, 2011
65 gem 'launchy'
0941b00 @kirs Enable assets
kirs authored Nov 25, 2014
66 gem 'rack-test', require: 'rack/test'
4767551 @u2 Replace rr gem with mocha mock
u2 authored Jun 27, 2015
67 gem 'mocha', require: false
68 gem 'bourne', require: false
0941b00 @kirs Enable assets
kirs authored Nov 25, 2014
69 gem 'shoulda', require: false
c51174f Get gemcutter running on the bundler
Carl Lerche authored Oct 9, 2009
70 end
cfea7d1 @sferik Try removing explicit yaml requires to fix syck bug
sferik authored Aug 16, 2011
71
cc33ca1 @dwradcliffe migrate to capistrano 3
dwradcliffe authored May 18, 2015
72 group :development, :deploy do
73 gem 'capistrano', '~> 3.0', require: false
74 gem 'capistrano-rails', '~> 1.1', require: false
75 gem 'capistrano-bundler', '~> 1.1', require: false
76 end
Something went wrong with that request. Please try again.