Skip to content
Browse files

Add test-unit gem to fix the build on MRI 1.9.3

  • Loading branch information...
1 parent 74e4357 commit 6a8bd3437ce4b02f0457683dfc68d625b3d04c0c @sferik sferik committed Mar 12, 2012
Showing with 3 additions and 0 deletions.
  1. +1 −0 Gemfile
  2. +2 −0 Gemfile.lock
  3. BIN vendor/cache/test-unit-2.4.8.gem
View
1 Gemfile
@@ -50,6 +50,7 @@ group :test do
gem 'redgreen', :platforms => :ruby_18
gem 'rr'
gem 'shoulda'
+ gem 'test-unit'
gem 'timecop'
gem 'webmock'
end
View
2 Gemfile.lock
@@ -196,6 +196,7 @@ GEM
slop (2.4.4)
system_timer (1.2.4)
term-ansicolor (1.0.7)
+ test-unit (2.4.8)
thor (0.14.6)
tilt (1.3.3)
timecop (0.3.5)
@@ -262,6 +263,7 @@ DEPENDENCIES
silent-postgres
sinatra
system_timer
+ test-unit
timecop
validates_formatting_of (>= 0.3.0)
webmock
View
BIN vendor/cache/test-unit-2.4.8.gem
Binary file not shown.

2 comments on commit 6a8bd34

@qrush
RubyGems member
qrush commented on 6a8bd34 Mar 20, 2012

Just had to revert this in master, @sferik. I wasn't seeing test-unit output. Not sure what's up with that, but I'm OK with only testing on 1.9.3 if we can get that working. (The app runs on that in production and locally for me)

@qrush
RubyGems member
qrush commented on 6a8bd34 Mar 20, 2012

Maybe this will help.

Without the test-unit gem:

[master][~/Dev/rubygems.org] ruby -Itest test/unit/dependency_test.rb
Installing Redis instrumentation
Cannot find or read /Users/qrush/Dev/rubygems.org/config/newrelic.yml
Run options: 

# Running tests:

.................

Finished tests in 0.462383s, 36.7661 tests/s, 75.6948 assertions/s.

With:

[master][~/Dev/rubygems.org] ruby -Itest test/unit/dependency_test.rb 
Installing Redis instrumentation
Cannot find or read /Users/qrush/Dev/rubygems.org/config/newrelic.yml
Loaded suite test/unit/dependency_test
Started


Finished in 0.459437 seconds.

17 tests, 35 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0 notifications
0% passed
Please sign in to comment.
Something went wrong with that request. Please try again.