Permalink
Browse files

Try removing explicit yaml requires to fix syck bug

  • Loading branch information...
1 parent 8c06ce3 commit c61c40dbfb09b95d564972ba5d26128419e72640 @sferik sferik committed Aug 17, 2011
View
@@ -1,8 +1,5 @@
source 'http://rubygems.org'
-# Load psych before anything else, since load order is significant in defining YAML::ENGINE.yamler
-gem 'psych', :platforms => :ruby_19
-
gem 'rails', '~> 3.0.10'
gem 'clearance', '~> 0.9.1'
@@ -25,29 +22,18 @@ gem 'will_paginate'
gem 'xml-simple'
gem 'yajl-ruby', :require => 'yajl/json_gem'
-platforms :ruby_18 do
- gem 'system_timer'
- group :test do
- gem 'redgreen'
- end
-end
-
-platforms :jruby do
- gem 'jruby-openssl'
-end
-
group :development do
gem 'rails-erd'
end
+group :development, :test do
+ gem 'silent-postgres'
+end
+
# These gems suck and do stupid things when in maintenance mode
group :development, :test, :staging, :production do
gem 'delayed_job'
- gem 'validates_url_format_of', '~> 0.1.2'
-end
-
-group :development, :test do
- gem 'silent-postgres'
+ gem 'validates_url_format_of'
end
group :test do
@@ -57,8 +43,21 @@ group :test do
gem 'launchy'
gem 'nokogiri'
gem 'rack-test', :require => 'rack/test'
+ gem 'redgreen', :platforms => :ruby_18
gem 'rr'
gem 'shoulda'
gem 'timecop'
gem 'webmock'
end
+
+platforms :jruby do
+ gem 'jruby-openssl'
+end
+
+platforms :ruby_18 do
+ gem 'system_timer'
+end
+
+platforms :ruby_19 do
+ gem 'psych'
+end
@@ -1,5 +1,3 @@
-require 'yaml'
-
class Api::V1::OwnersController < Api::BaseController
skip_before_filter :verify_authenticity_token, :only => [:create, :destroy]
@@ -1,5 +1,3 @@
-require 'yaml'
-
class Api::V1::RubygemsController < Api::BaseController
skip_before_filter :verify_authenticity_token, :only => [:create, :yank, :unyank]
@@ -1,5 +1,3 @@
-require 'yaml'
-
class Api::V1::SearchesController < Api::BaseController
skip_before_filter :verify_authenticity_token
@@ -1,5 +1,3 @@
-require 'yaml'
-
class Api::V1::WebHooksController < Api::BaseController
skip_before_filter :verify_authenticity_token
@@ -1 +0,0 @@
-require 'psych' if RUBY_VERSION >= "1.9"
@@ -1,5 +1,4 @@
require 'test_helper'
-require 'yaml'
class Api::V1::RubygemsControllerTest < ActionController::TestCase
should "route old paths to new controller" do
@@ -1,5 +1,4 @@
require 'test_helper'
-require 'yaml'
class Api::V1::SearchesControllerTest < ActionController::TestCase
context "with some gems" do
@@ -1,5 +1,4 @@
require 'test_helper'
-require 'yaml'
class Api::V1::WebHooksControllerTest < ActionController::TestCase
def self.should_not_find_it

0 comments on commit c61c40d

Please sign in to comment.