Skip to content
This repository
Browse code

Updating gemspec so it actually builds

  • Loading branch information...
commit dbed38daf5886eba9cf95af9b9efe4e7105ed495 1 parent db7adba
Nick Quaranto qrush authored

Showing 2 changed files with 8 additions and 25 deletions. Show diff stats Hide diff stats

  1. +3 1 Rakefile
  2. +5 24 gemcutter.gemspec
4 Rakefile
@@ -106,10 +106,12 @@ begin
106 106 require 'jeweler'
107 107 Jeweler::Tasks.new do |gem|
108 108 gem.name = "gemcutter"
109   - gem.summary = "Simple and kickass gem hosting"
  109 + gem.summary = "Kickass gem hosting"
110 110 gem.email = "nick@quaran.to"
111 111 gem.homepage = "http://github.com/qrush/gemcutter"
112 112 gem.authors = ["Nick Quaranto"]
  113 + gem.files = FileList["lib/rubygems_plugin.rb", "lib/commands/*"]
  114 + gem.test_files = []
113 115 end
114 116 rescue LoadError
115 117 puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
29 gemcutter.gemspec
@@ -6,41 +6,22 @@ Gem::Specification.new do |s|
6 6
7 7 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
8 8 s.authors = ["Nick Quaranto"]
9   - s.date = %q{2009-05-24}
  9 + s.date = %q{2009-05-30}
10 10 s.email = %q{nick@quaran.to}
11 11 s.extra_rdoc_files = [
12 12 "README.textile"
13 13 ]
14 14 s.files = [
15   - "README.textile",
16   - "Rakefile",
17   - "VERSION.yml",
18 15 "lib/commands/downgrade.rb",
19   - "lib/commands/push.rb",
20   - "lib/commands/upgrade.rb",
21   - "lib/gemcutter.rb",
22   - "lib/rubygems_plugin.rb",
23   - "spec/app_spec.rb",
24   - "spec/cutter_spec.rb",
25   - "spec/gem_spec.rb",
26   - "spec/gems/test-0.0.0.gem",
27   - "spec/gems/test-0.0.0.gem_up",
28   - "spec/gems/test-1.0.0.gem",
29   - "spec/indexer_spec.rb",
30   - "spec/spec_helper.rb"
  16 + "lib/commands/push.rb",
  17 + "lib/commands/upgrade.rb",
  18 + "lib/rubygems_plugin.rb"
31 19 ]
32 20 s.homepage = %q{http://github.com/qrush/gemcutter}
33 21 s.rdoc_options = ["--charset=UTF-8"]
34 22 s.require_paths = ["lib"]
35 23 s.rubygems_version = %q{1.3.3}
36   - s.summary = %q{Simple and kickass gem hosting}
37   - s.test_files = [
38   - "spec/app_spec.rb",
39   - "spec/cutter_spec.rb",
40   - "spec/gem_spec.rb",
41   - "spec/indexer_spec.rb",
42   - "spec/spec_helper.rb"
43   - ]
  24 + s.summary = %q{Kickass gem hosting}
44 25
45 26 if s.respond_to? :specification_version then
46 27 current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION

0 comments on commit dbed38d

Please sign in to comment.
Something went wrong with that request. Please try again.