Skip to content

Loading…

Rails 3.1.3, without the asset pipeline. #405

Closed
wants to merge 8 commits into from

2 participants

@cmeiklejohn

This moves the app to rails 3.1.3, without introducing the asset pipeline which will be done in a later commit; keeping with the tradition of smaller, easier to review pull requests.

Everything is functioning correctly at this time, except for these errors when pushing gems via the cucumber suite.

invalid %-encoding (data.tar.gz0000644000000000000000000000004300000000000013314 0ustar00wheelwheel00000000000000�L�IO�b`��`��T���.����metadata.gz0000644000000000000000000000071100000000000013400 0ustar00wheelwheel00000000000000�L�IO��Sˮ�0���+|W]%u���@,��X����,Ǚ) (ArgumentError)
      /home/cmeiklejohn/.rbenv/versions/1.9.3-p0/lib/ruby/1.9.1/uri/common.rb:911:in `decode_www_form_component'

See: https://groups.google.com/forum/?fromgroups#!topic/rack-devel/Pk2DMRI8E6Y and rack/rack#337 as they appear to be related.

cmeiklejohn added some commits
@cmeiklejohn cmeiklejohn Bump dependencies. e748367
@cmeiklejohn cmeiklejohn Use securerandom. 013506a
@cmeiklejohn cmeiklejohn Kill rjs. 2b66efa
@cmeiklejohn cmeiklejohn Replace deprecated assert_valid with preferred assert valid?. a018741
@cmeiklejohn cmeiklejohn Update to use template and supply correct format. 65100fd
@cmeiklejohn cmeiklejohn Ensure sorting. bcc5ec2
@cmeiklejohn cmeiklejohn Don't validate through the versions association.
This is necessary because we transactionally save the rubygem, first,
and then update the versions with the fields we validate on save and
rollback afterwards on error.  If we attempt to validate on save of the
rubygem, through the association, none of the versions will be valid.
1f37220
@cmeiklejohn cmeiklejohn Update nokogiri parsing. b390a50
@cmeiklejohn

We could refactor the Rubygem#update_attributes_from_gem_specification ordering to get around this.

@qrush
RubyGems member

Merged the other Rails 3.1 stuff instead, closing this!

@qrush qrush closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Feb 26, 2012
  1. @cmeiklejohn

    Bump dependencies.

    cmeiklejohn committed
  2. @cmeiklejohn

    Use securerandom.

    cmeiklejohn committed
  3. @cmeiklejohn

    Kill rjs.

    cmeiklejohn committed
  4. @cmeiklejohn
  5. @cmeiklejohn
  6. @cmeiklejohn

    Ensure sorting.

    cmeiklejohn committed
  7. @cmeiklejohn

    Don't validate through the versions association.

    cmeiklejohn committed
    This is necessary because we transactionally save the rubygem, first,
    and then update the versions with the fields we validate on save and
    rollback afterwards on error.  If we attempt to validate on save of the
    rubygem, through the association, none of the versions will be valid.
  8. @cmeiklejohn

    Update nokogiri parsing.

    cmeiklejohn committed
This page is out of date. Refresh to see the latest.
Showing with 109 additions and 88 deletions.
  1. +1 −1 Gemfile
  2. +82 −65 Gemfile.lock
  3. +1 −1 app/controllers/subscriptions_controller.rb
  4. +2 −2 app/models/rubygem.rb
  5. +1 −1 app/models/user.rb
  6. +4 −0 app/models/version.rb
  7. +1 −0 app/views/subscriptions/update.js.erb
  8. +0 −1 config/environments/development.rb
  9. +1 −1 test/functional/api/v1/web_hooks_controller_test.rb
  10. +4 −4 test/functional/subscriptions_controller_test.rb
  11. +1 −1 test/unit/dependency_test.rb
  12. +1 −1 test/unit/linkset_test.rb
  13. +1 −1 test/unit/ownership_test.rb
  14. +1 −1 test/unit/subscription_test.rb
  15. +2 −2 test/unit/user_test.rb
  16. +6 −6 test/unit/web_hook_test.rb
  17. BIN vendor/cache/abstract-1.0.0.gem
  18. BIN vendor/cache/actionmailer-3.0.11.gem
  19. BIN vendor/cache/actionmailer-3.1.3.gem
  20. BIN vendor/cache/actionpack-3.0.11.gem
  21. BIN vendor/cache/actionpack-3.1.3.gem
  22. BIN vendor/cache/activemodel-3.0.11.gem
  23. BIN vendor/cache/activemodel-3.1.3.gem
  24. BIN vendor/cache/activerecord-3.0.11.gem
  25. BIN vendor/cache/activerecord-3.1.3.gem
  26. BIN vendor/cache/activeresource-3.0.11.gem
  27. BIN vendor/cache/activeresource-3.1.3.gem
  28. BIN vendor/cache/activesupport-3.0.11.gem
  29. BIN vendor/cache/activesupport-3.1.3.gem
  30. BIN vendor/cache/arel-2.0.10.gem
  31. BIN vendor/cache/arel-2.2.3.gem
  32. BIN vendor/cache/builder-2.1.2.gem
  33. BIN vendor/cache/builder-3.0.0.gem
  34. BIN vendor/cache/erubis-2.6.6.gem
  35. BIN vendor/cache/erubis-2.7.0.gem
  36. BIN vendor/cache/fog-0.7.2.gem
  37. BIN vendor/cache/fog-1.1.2.gem
  38. BIN vendor/cache/hike-1.2.1.gem
  39. BIN vendor/cache/i18n-0.5.0.gem
  40. BIN vendor/cache/i18n-0.6.0.gem
  41. BIN vendor/cache/json_pure-1.6.5.gem
  42. BIN vendor/cache/mail-2.2.19.gem
  43. BIN vendor/cache/mail-2.3.0.gem
  44. BIN vendor/cache/multi_json-1.0.4.gem
  45. BIN vendor/cache/multi_json-1.1.0.gem
  46. BIN vendor/cache/rack-1.2.5.gem
  47. BIN vendor/cache/rack-1.3.6.gem
  48. BIN vendor/cache/rack-cache-1.1.gem
  49. BIN vendor/cache/rack-mount-0.6.14.gem
  50. BIN vendor/cache/rack-mount-0.8.3.gem
  51. BIN vendor/cache/rack-protection-1.2.0.gem
  52. BIN vendor/cache/rack-ssl-1.3.2.gem
  53. BIN vendor/cache/rack-test-0.5.7.gem
  54. BIN vendor/cache/rack-test-0.6.1.gem
  55. BIN vendor/cache/{rails-3.0.11.gem → rails-3.1.3.gem}
  56. BIN vendor/cache/railties-3.0.11.gem
  57. BIN vendor/cache/railties-3.1.3.gem
  58. BIN vendor/cache/selenium-webdriver-2.13.0.gem
  59. BIN vendor/cache/selenium-webdriver-2.19.0.gem
  60. BIN vendor/cache/shoulda-2.11.3.gem
  61. BIN vendor/cache/shoulda-3.0.0.gem
  62. BIN vendor/cache/shoulda-context-1.0.0.gem
  63. BIN vendor/cache/shoulda-matchers-1.0.0.gem
  64. BIN vendor/cache/sinatra-1.2.8.gem
  65. BIN vendor/cache/sinatra-1.3.2.gem
  66. BIN vendor/cache/sprockets-2.0.3.gem
  67. BIN vendor/cache/webmock-1.7.10.gem
  68. BIN vendor/cache/webmock-1.8.0.gem
View
2 Gemfile
@@ -1,6 +1,6 @@
source 'https://rubygems.org'
-gem 'rails', '~> 3.0.10'
+gem 'rails', '~> 3.1.0'
gem 'airbrake'
gem 'clearance', '~> 0.13.2'
View
147 Gemfile.lock
@@ -1,39 +1,40 @@
GEM
remote: https://rubygems.org/
specs:
- abstract (1.0.0)
- actionmailer (3.0.11)
- actionpack (= 3.0.11)
- mail (~> 2.2.19)
- actionpack (3.0.11)
- activemodel (= 3.0.11)
- activesupport (= 3.0.11)
- builder (~> 2.1.2)
- erubis (~> 2.6.6)
- i18n (~> 0.5.0)
- rack (~> 1.2.1)
- rack-mount (~> 0.6.14)
- rack-test (~> 0.5.7)
- tzinfo (~> 0.3.23)
- activemodel (3.0.11)
- activesupport (= 3.0.11)
- builder (~> 2.1.2)
- i18n (~> 0.5.0)
- activerecord (3.0.11)
- activemodel (= 3.0.11)
- activesupport (= 3.0.11)
- arel (~> 2.0.10)
- tzinfo (~> 0.3.23)
- activeresource (3.0.11)
- activemodel (= 3.0.11)
- activesupport (= 3.0.11)
- activesupport (3.0.11)
+ actionmailer (3.1.3)
+ actionpack (= 3.1.3)
+ mail (~> 2.3.0)
+ actionpack (3.1.3)
+ activemodel (= 3.1.3)
+ activesupport (= 3.1.3)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ i18n (~> 0.6)
+ rack (~> 1.3.5)
+ rack-cache (~> 1.1)
+ rack-mount (~> 0.8.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.0.3)
+ activemodel (3.1.3)
+ activesupport (= 3.1.3)
+ builder (~> 3.0.0)
+ i18n (~> 0.6)
+ activerecord (3.1.3)
+ activemodel (= 3.1.3)
+ activesupport (= 3.1.3)
+ arel (~> 2.2.1)
+ tzinfo (~> 0.3.29)
+ activeresource (3.1.3)
+ activemodel (= 3.1.3)
+ activesupport (= 3.1.3)
+ activesupport (3.1.3)
+ multi_json (~> 1.0)
addressable (2.2.7)
airbrake (3.0.9)
activesupport
builder
- arel (2.0.10)
- builder (2.1.2)
+ arel (2.2.3)
+ builder (3.0.0)
capistrano (2.11.2)
highline
net-scp (>= 1.0.0)
@@ -76,8 +77,7 @@ GEM
diesel (0.1.5)
railties
diff-lcs (1.1.3)
- erubis (2.6.6)
- abstract (>= 1.0.0)
+ erubis (2.7.0)
excon (0.9.6)
factory_girl (2.6.0)
activesupport (>= 2.3.9)
@@ -85,15 +85,14 @@ GEM
factory_girl (~> 2.6.0)
railties (>= 3.0.0)
ffi (1.0.11)
- fog (1.1.2)
+ fog (0.7.2)
builder
- excon (~> 0.9.0)
- formatador (~> 0.2.0)
+ excon (>= 0.6.1)
+ formatador (>= 0.1.3)
+ json
mime-types
- multi_json (~> 1.0.3)
- net-scp (~> 1.0.4)
net-ssh (>= 2.1.3)
- nokogiri (~> 1.5.0)
+ nokogiri (>= 1.4.4)
ruby-hmac
formatador (0.2.1)
gchartrb (0.8)
@@ -111,21 +110,22 @@ GEM
guard (>= 0.8.3)
high_voltage (1.1.1)
highline (1.6.11)
- i18n (0.5.0)
+ hike (1.2.1)
+ i18n (0.6.0)
jquery-rails (1.0.19)
railties (~> 3.0)
thor (~> 0.14)
json (1.6.5)
+ json_pure (1.6.5)
launchy (2.0.5)
addressable (~> 2.2.6)
- mail (2.2.19)
- activesupport (>= 2.3.6)
+ mail (2.3.0)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
method_source (0.7.0)
mime-types (1.17.2)
- multi_json (1.0.4)
+ multi_json (1.1.0)
net-scp (1.0.4)
net-ssh (>= 1.99.1)
net-sftp (2.0.5)
@@ -143,35 +143,43 @@ GEM
coderay (~> 1.0.5)
method_source (~> 0.7)
slop (>= 2.4.4, < 3)
- rack (1.2.5)
+ rack (1.3.6)
+ rack-cache (1.1)
+ rack (>= 0.4)
rack-maintenance (0.3.0)
rack (>= 1.0)
- rack-mount (0.6.14)
+ rack-mount (0.8.3)
rack (>= 1.0.0)
- rack-test (0.5.7)
+ rack-protection (1.2.0)
+ rack
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.1)
rack (>= 1.0)
- rails (3.0.11)
- actionmailer (= 3.0.11)
- actionpack (= 3.0.11)
- activerecord (= 3.0.11)
- activeresource (= 3.0.11)
- activesupport (= 3.0.11)
+ rails (3.1.3)
+ actionmailer (= 3.1.3)
+ actionpack (= 3.1.3)
+ activerecord (= 3.1.3)
+ activeresource (= 3.1.3)
+ activesupport (= 3.1.3)
bundler (~> 1.0)
- railties (= 3.0.11)
+ railties (= 3.1.3)
rails-erd (0.4.5)
activerecord (~> 3.0)
activesupport (~> 3.0)
ruby-graphviz (~> 0.9.18)
- railties (3.0.11)
- actionpack (= 3.0.11)
- activesupport (= 3.0.11)
+ railties (3.1.3)
+ actionpack (= 3.1.3)
+ activesupport (= 3.1.3)
+ rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
- thor (~> 0.14.4)
+ thor (~> 0.14.6)
rake (0.9.2.2)
rdoc (3.12)
json (~> 1.4)
redgreen (1.2.2)
+ rake
redis (2.2.2)
rest-client (1.6.7)
mime-types (>= 1.16)
@@ -180,17 +188,26 @@ GEM
ruby-hmac (0.4.0)
rubyzip (0.9.6.1)
rvm (1.9.2)
- selenium-webdriver (2.19.0)
- childprocess (>= 0.2.5)
+ selenium-webdriver (2.13.0)
+ childprocess (>= 0.2.1)
ffi (~> 1.0.9)
- multi_json (~> 1.0.4)
+ json_pure
rubyzip
- shoulda (2.11.3)
+ shoulda (3.0.0)
+ shoulda-context (~> 1.0.0)
+ shoulda-matchers (~> 1.0.0)
+ shoulda-context (1.0.0)
+ shoulda-matchers (1.0.0)
silent-postgres (0.1.1)
- sinatra (1.2.8)
- rack (~> 1.1)
- tilt (>= 1.2.2, < 2.0)
+ sinatra (1.3.2)
+ rack (~> 1.3, >= 1.3.6)
+ rack-protection (~> 1.2)
+ tilt (~> 1.3, >= 1.3.3)
slop (2.4.4)
+ sprockets (2.0.3)
+ hike (~> 1.2)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
system_timer (1.2.4)
term-ansicolor (1.0.7)
thor (0.14.6)
@@ -202,8 +219,8 @@ GEM
tzinfo (0.3.31)
validates_formatting_of (0.4.1)
rails (~> 3.0)
- webmock (1.7.10)
- addressable (~> 2.2, > 2.2.5)
+ webmock (1.8.0)
+ addressable (>= 2.2.7)
crack (>= 0.1.7)
will_paginate (3.0.3)
xml-simple (1.1.1)
@@ -246,7 +263,7 @@ DEPENDENCIES
rack
rack-maintenance
rack-test
- rails (~> 3.0.10)
+ rails (~> 3.1.0)
rails-erd
rdoc
redgreen
View
2 app/controllers/subscriptions_controller.rb
@@ -15,7 +15,7 @@ def destroy
def render_toggle_or_unacceptable(success)
if success
- render(:update) { |page| page['.toggler'].toggle }
+ render :update
else
render :text => '', :status => :forbidden
end
View
4 app/models/rubygem.rb
@@ -5,7 +5,7 @@ class Rubygem < ActiveRecord::Base
has_many :ownerships, :dependent => :destroy
has_many :subscribers, :through => :subscriptions, :source => :user
has_many :subscriptions, :dependent => :destroy
- has_many :versions, :dependent => :destroy
+ has_many :versions, :dependent => :destroy, :validate => false
has_many :web_hooks, :dependent => :destroy
has_one :linkset, :dependent => :destroy
@@ -236,7 +236,7 @@ def monthly_downloads
end
def first_built_date
- versions.by_built_at.limit(1).last.built_at
+ versions.by_earliest_built_at.limit(1).last.built_at
end
private
View
2 app/models/user.rb
@@ -79,7 +79,7 @@ def regenerate_token
end
def generate_api_key
- self.api_key = ActiveSupport::SecureRandom.hex(16)
+ self.api_key = SecureRandom.hex(16)
end
def total_downloads_count
View
4 app/models/version.rb
@@ -54,6 +54,10 @@ def self.by_built_at
order("versions.built_at desc")
end
+ def self.by_earliest_built_at
+ order("versions.built_at asc")
+ end
+
def self.by_created_at
order('versions.created_at desc')
end
View
1 app/views/subscriptions/update.js.erb
@@ -0,0 +1 @@
+$(".toggler").toggle();
View
1 config/environments/development.rb
@@ -3,7 +3,6 @@
config.whiny_nils = true
config.consider_all_requests_local = true
- config.action_view.debug_rjs = true
config.action_controller.perform_caching = false
config.active_support.deprecation = :log
config.action_mailer.raise_delivery_errors = false
View
2 test/functional/api/v1/web_hooks_controller_test.rb
@@ -140,7 +140,7 @@ def self.should_respond_to(format)
should_respond_to(:xml) do |body|
children = Nokogiri.parse(body).root.children
Hash.from_xml(children[1].to_xml).update(
- 'all gems' => [Hash.from_xml(children[5].to_xml)['web_hook']]
+ 'all gems' => Hash.from_xml(children[3].to_xml).delete('all_gems')
)
end
View
8 test/functional/subscriptions_controller_test.rb
@@ -12,7 +12,7 @@ class SubscriptionsControllerTest < ActionController::TestCase
setup do
@rubygem = Factory(:rubygem)
Factory(:version, :rubygem => @rubygem)
- post :create, :rubygem_id => @rubygem.to_param
+ post :create, :rubygem_id => @rubygem.to_param, :format => 'js'
end
should assign_to(:rubygem) { @rubygem }
@@ -27,7 +27,7 @@ class SubscriptionsControllerTest < ActionController::TestCase
@rubygem = Factory(:rubygem)
Factory(:version, :rubygem => @rubygem)
Factory(:subscription, :rubygem => @rubygem, :user => @user)
- post :create, :rubygem_id => @rubygem.to_param
+ post :create, :rubygem_id => @rubygem.to_param, :format => 'js'
end
should assign_to(:rubygem) { @rubygem }
@@ -38,7 +38,7 @@ class SubscriptionsControllerTest < ActionController::TestCase
setup do
@rubygem = Factory(:rubygem)
Factory(:version, :rubygem => @rubygem)
- delete :destroy, :rubygem_id => @rubygem.to_param
+ delete :destroy, :rubygem_id => @rubygem.to_param, :format => 'js'
end
should assign_to(:rubygem) { @rubygem }
@@ -50,7 +50,7 @@ class SubscriptionsControllerTest < ActionController::TestCase
@rubygem = Factory(:rubygem)
Factory(:version, :rubygem => @rubygem)
Factory(:subscription, :rubygem => @rubygem, :user => @user)
- delete :destroy, :rubygem_id => @rubygem.to_param
+ delete :destroy, :rubygem_id => @rubygem.to_param, :format => 'js'
end
should assign_to(:rubygem) { @rubygem }
View
2 test/unit/dependency_test.rb
@@ -11,7 +11,7 @@ class DependencyTest < ActiveSupport::TestCase
end
should "be valid with factory" do
- assert_valid @dependency
+ assert @dependency.valid?
end
should "return JSON" do
View
2 test/unit/linkset_test.rb
@@ -10,7 +10,7 @@ class LinksetTest < ActiveSupport::TestCase
end
should "be valid with factory" do
- assert_valid @linkset
+ assert @linkset.valid?
end
should "not be empty with some links filled out" do
View
2 test/unit/ownership_test.rb
@@ -2,7 +2,7 @@
class OwnershipTest < ActiveSupport::TestCase
should "be valid with factory" do
- assert_valid FactoryGirl.build(:ownership)
+ assert FactoryGirl.build(:ownership).valid?
end
should belong_to :rubygem
View
2 test/unit/subscription_test.rb
@@ -14,7 +14,7 @@ class SubscriptionTest < ActiveSupport::TestCase
should validate_uniqueness_of(:rubygem_id).scoped_to(:user_id)
should "be valid with factory" do
- assert_valid @subscription
+ assert @subscription.valid?
end
end
end
View
4 test/unit/user_test.rb
@@ -34,8 +34,8 @@ class UserTest < ActiveSupport::TestCase
end
should "be valid when nil and other users have a nil handle" do
- assert_valid FactoryGirl.build(:user, :handle => nil)
- assert_valid FactoryGirl.build(:user, :handle => nil)
+ assert FactoryGirl.build(:user, :handle => nil).valid?
+ assert FactoryGirl.build(:user, :handle => nil).valid?
end
should "show user id if no handle set" do
View
12 test/unit/web_hook_test.rb
@@ -48,14 +48,14 @@ class WebHookTest < ActiveSupport::TestCase
should "be able to create a webhook for a url under this user and gem" do
webhook = WebHook.new(:user => @user,
:url => "http://example.net")
- assert_valid webhook
+ assert webhook.valid?
end
should "be able to create a webhook for another user under this url" do
other_user = Factory(:user)
webhook = WebHook.new(:user => other_user,
:url => @url)
- assert_valid webhook
+ assert webhook.valid?
end
end
@@ -105,7 +105,7 @@ class WebHookTest < ActiveSupport::TestCase
webhook = WebHook.new(:user => @user,
:rubygem => @rubygem,
:url => "http://example.net")
- assert_valid webhook
+ assert webhook.valid?
end
should "be able to create a webhook for another rubygem under this user and url" do
@@ -113,7 +113,7 @@ class WebHookTest < ActiveSupport::TestCase
webhook = WebHook.new(:user => @user,
:rubygem => other_rubygem,
:url => @url)
- assert_valid webhook
+ assert webhook.valid?
end
should "be able to create a webhook for another user under this rubygem and url" do
@@ -121,13 +121,13 @@ class WebHookTest < ActiveSupport::TestCase
webhook = WebHook.new(:user => other_user,
:rubygem => @rubygem,
:url => @url)
- assert_valid webhook
+ assert webhook.valid?
end
should "be able to create a global webhook under this user and url" do
webhook = WebHook.new(:user => @user,
:url => @url)
- assert_valid webhook
+ assert webhook.valid?
end
end
View
BIN vendor/cache/abstract-1.0.0.gem
Binary file not shown.
View
BIN vendor/cache/actionmailer-3.0.11.gem
Binary file not shown.
View
BIN vendor/cache/actionmailer-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/actionpack-3.0.11.gem
Binary file not shown.
View
BIN vendor/cache/actionpack-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/activemodel-3.0.11.gem
Binary file not shown.
View
BIN vendor/cache/activemodel-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/activerecord-3.0.11.gem
Binary file not shown.
View
BIN vendor/cache/activerecord-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/activeresource-3.0.11.gem
Binary file not shown.
View
BIN vendor/cache/activeresource-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/activesupport-3.0.11.gem
Binary file not shown.
View
BIN vendor/cache/activesupport-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/arel-2.0.10.gem
Binary file not shown.
View
BIN vendor/cache/arel-2.2.3.gem
Binary file not shown.
View
BIN vendor/cache/builder-2.1.2.gem
Binary file not shown.
View
BIN vendor/cache/builder-3.0.0.gem
Binary file not shown.
View
BIN vendor/cache/erubis-2.6.6.gem
Binary file not shown.
View
BIN vendor/cache/erubis-2.7.0.gem
Binary file not shown.
View
BIN vendor/cache/fog-0.7.2.gem
Binary file not shown.
View
BIN vendor/cache/fog-1.1.2.gem
Binary file not shown.
View
BIN vendor/cache/hike-1.2.1.gem
Binary file not shown.
View
BIN vendor/cache/i18n-0.5.0.gem
Binary file not shown.
View
BIN vendor/cache/i18n-0.6.0.gem
Binary file not shown.
View
BIN vendor/cache/json_pure-1.6.5.gem
Binary file not shown.
View
BIN vendor/cache/mail-2.2.19.gem
Binary file not shown.
View
BIN vendor/cache/mail-2.3.0.gem
Binary file not shown.
View
BIN vendor/cache/multi_json-1.0.4.gem
Binary file not shown.
View
BIN vendor/cache/multi_json-1.1.0.gem
Binary file not shown.
View
BIN vendor/cache/rack-1.2.5.gem
Binary file not shown.
View
BIN vendor/cache/rack-1.3.6.gem
Binary file not shown.
View
BIN vendor/cache/rack-cache-1.1.gem
Binary file not shown.
View
BIN vendor/cache/rack-mount-0.6.14.gem
Binary file not shown.
View
BIN vendor/cache/rack-mount-0.8.3.gem
Binary file not shown.
View
BIN vendor/cache/rack-protection-1.2.0.gem
Binary file not shown.
View
BIN vendor/cache/rack-ssl-1.3.2.gem
Binary file not shown.
View
BIN vendor/cache/rack-test-0.5.7.gem
Binary file not shown.
View
BIN vendor/cache/rack-test-0.6.1.gem
Binary file not shown.
View
BIN vendor/cache/rails-3.0.11.gem → vendor/cache/rails-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/railties-3.0.11.gem
Binary file not shown.
View
BIN vendor/cache/railties-3.1.3.gem
Binary file not shown.
View
BIN vendor/cache/selenium-webdriver-2.13.0.gem
Binary file not shown.
View
BIN vendor/cache/selenium-webdriver-2.19.0.gem
Binary file not shown.
View
BIN vendor/cache/shoulda-2.11.3.gem
Binary file not shown.
View
BIN vendor/cache/shoulda-3.0.0.gem
Binary file not shown.
View
BIN vendor/cache/shoulda-context-1.0.0.gem
Binary file not shown.
View
BIN vendor/cache/shoulda-matchers-1.0.0.gem
Binary file not shown.
View
BIN vendor/cache/sinatra-1.2.8.gem
Binary file not shown.
View
BIN vendor/cache/sinatra-1.3.2.gem
Binary file not shown.
View
BIN vendor/cache/sprockets-2.0.3.gem
Binary file not shown.
View
BIN vendor/cache/webmock-1.7.10.gem
Binary file not shown.
View
BIN vendor/cache/webmock-1.8.0.gem
Binary file not shown.
Something went wrong with that request. Please try again.