Permalink
Browse files

Remove deprecated Gem.activate_dep

It is described that "will be removed on or after 2011-06".
  • Loading branch information...
1 parent 83fa027 commit 058c92877b9b45ad4c0b3f338ca9517931793133 @kou kou committed Sep 16, 2012
Showing with 0 additions and 5 deletions.
  1. +0 −5 lib/rubygems.rb
View
5 lib/rubygems.rb
@@ -188,10 +188,6 @@ def self.activate(dep, *requirements)
Gem::Specification.find_by_name(dep, *requirements).activate
end
- def self.activate_dep dep, *requirements # :nodoc:
- dep.to_spec.activate
- end
-
def self.activate_spec spec # :nodoc:
spec.activate
end
@@ -1314,7 +1310,6 @@ def RbConfig.datadir(package_name) # :nodoc:
module Gem
class << self
extend Gem::Deprecate
- deprecate :activate_dep, "Specification#activate", 2011, 6
deprecate :activate_spec, "Specification#activate", 2011, 6
deprecate :activate, "Specification#activate", 2011, 10
deprecate :all_load_paths, :none, 2011, 10

0 comments on commit 058c928

Please sign in to comment.