Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Renamed require__ to gem_original_require.

git-svn-id: svn+ssh://rubyforge.org/var/svn/rubygems/trunk@942 3d4018f9-ac1a-0410-99e9-8a154d859a19
  • Loading branch information...
commit 575cc51cb78397129bc2561b8249f973e90be99b 1 parent 632f6fb
@jimweirich jimweirich authored
Showing with 3 additions and 3 deletions.
  1. +3 −3 rubygems/lib/rubygems/custom_require.rb
View
6 rubygems/lib/rubygems/custom_require.rb
@@ -1,7 +1,7 @@
require 'rubygems/source_index'
module Kernel
- alias require__ require
+ alias gem_original_require require
#
# We replace Ruby's require with our own, which is capable of
@@ -18,13 +18,13 @@ module Kernel
# that file has already been loaded is preserved.
#
def require(path)
- require__ path
+ gem_original_require path
rescue LoadError => load_error
begin
@gempath_searcher ||= Gem::GemPathSearcher.new
if spec = @gempath_searcher.find(path)
Gem.activate(spec.name, false, "= #{spec.version}")
- require__ path
+ gem_original_require path
else
raise load_error
end
Please sign in to comment.
Something went wrong with that request. Please try again.