Permalink
Browse files

Update History.txt

git-svn-id: svn+ssh://rubyforge.org/var/svn/rubygems/trunk@2386 3d4018f9-ac1a-0410-99e9-8a154d859a19
  • Loading branch information...
1 parent 836e255 commit 73a084183081933d72b1909fa27d0c16fae09c7c @drbrain drbrain committed Feb 9, 2010
Showing with 44 additions and 3 deletions.
  1. +1 −0 ChangeLog
  2. +41 −1 History.txt
  3. +1 −1 lib/rubygems/dependency.rb
  4. +1 −1 util/CL2notes
View
@@ -111,6 +111,7 @@
2009-07-21 Eric Hodel <drbrain@segment7.net>
+ * lib/rubygems.rb: 1.3.5.
* lib/rubygems/package.rb: Remove dangling digest require. Reported
by Jeremy Kemper.
View
@@ -1,4 +1,44 @@
-=== 1.3.5 / 2009-06-??
+New features:
+
+* `gem` commands
+ * Added `gem push` and `gem owner` for interacting with modern/Gemcutter
+ sources
+ * `gem dep` now supports --prerelease.
+ * `gem fetch` now supports --prerelease.
+ * `gem server` now supports --bind. Patch #27357 by Bruno Michel.
+ * `gem rdoc` no longer overwrites built documentation. Use --overwrite
+ force rebuilding. Patch #25982 by Akinori MUSHA.
+ * --source is now additive, not exclusive. If exclusive sources are desired,
+ use --clear-sources first.
+* Captial letters are now allowed in prerelease versions.
+
+Bug fixes:
+
+* Development deps are no longer added to rubygems-update gem so older
+ versions can update sucessfully.
+* Installer bugs:
+ * Prerelease gems can now depend on non-prerelease gems.
+ * Development dependencies are ignored unless explicitly needed. Bug #27608
+ by Roger Pack.
+* `gem` commands
+ * `gem which` fails if no paths were found. Adapted patch #27681 by Caio
+ Chassot.
+ * `gem server` had invalid markup. Bug #27045 by Eric Young.
+* Gem::Format no longer crashes on empty files. Bug #27292 by Ian Ragsdale.
+* Gem::GemPathSearcher handles nil require_paths. Patch #27334 by Roger Pack.
+* Gem::RemoteFetcher no longer copies the file if it is where we want it.
+ Patch #27409 by Jakub Šťastný.
+
+Deprecation Notices:
+
+* lib/rubygems/timer.rb has been removed.
+* Gem::Dependency#version_requirements is deprecated and will be removed on or
+ after August 2010.
+* Bulk index update is no longer supported.
+* Gem::manage_gems was removed in 1.3.3.
+* Time::today was removed in 1.3.3.
+
+=== 1.3.5 / 2009-07-21
Bug fixes:
@@ -131,7 +131,7 @@ def to_s # :nodoc:
def version_requirements # :nodoc:
warn "Gem::Dependency#version_requirements is deprecated, " +
- " and will be removed on or after April 2010. " +
+ " and will be removed on or after August 2010. " +
" Use Gem::Dependency#requirement: #{caller.first}"
requirement
View
@@ -21,7 +21,7 @@ def format_text(text, wrap, indent=0)
result.join("\n").gsub(/^/, " " * indent)
end
-version = ARGV.shift || Gem::RubyGemsVersion
+version = ARGV.shift || Gem::VERSION
entries = Hash.new { |h,file| h[file] = [] }
entry = []

0 comments on commit 73a0841

Please sign in to comment.