Browse files

Better message about version minimum. Fixes #95

  • Loading branch information...
1 parent b99a830 commit 81a153106aaa1f9ac8095234480f3241cf7d0487 @evanphx evanphx committed Oct 6, 2012
Showing with 5 additions and 0 deletions.
  1. +5 −0 setup.rb
View
5 setup.rb
@@ -5,6 +5,11 @@
# See LICENSE.txt for permissions.
#++
+if RUBY_VERSION < "1.8.7"
+ $stderr.puts "Rubygems now requires Ruby 1.8.7 or later"
+ exit 1
+end
+
# Make sure rubygems isn't already loaded.
if ENV['RUBYOPT'] or defined? Gem then
ENV.delete 'RUBYOPT'

0 comments on commit 81a1531

Please sign in to comment.