Permalink
Browse files

Capture $VERBOSE early for ruby 1.8 and syck

I'm not sure how, but syck also disables warnings in a similar way and
this interfered with RubyGems enabling syck for tests.  This would cause
the contains_requirable_file? tests to fail on ruby 1.8 when ran after
with_syck.
  • Loading branch information...
1 parent ed7c39d commit e85f55014170f7af79eb9cbeed33df032802380f @drbrain drbrain committed Feb 5, 2014
Showing with 1 addition and 1 deletion.
  1. +1 −1 test/rubygems/test_gem_specification.rb
@@ -2986,9 +2986,9 @@ def util_setup_validate
def with_syck
begin
+ verbose, $VERBOSE = $VERBOSE, nil
require "yaml"
old_engine = YAML::ENGINE.yamler
- verbose, $VERBOSE = $VERBOSE, nil
YAML::ENGINE.yamler = 'syck'
load 'rubygems/syck_hack.rb'
rescue NameError

0 comments on commit e85f550

Please sign in to comment.