Skip to content

Loading…

Cleanup command misbehaving in 1.8.7 #148

Closed
baldowl opened this Issue · 5 comments

5 participants

@baldowl

The cleanup command in RubyGems 1.8.7 shows the following:

$ sudo gem cleanup rubygems-update
Cleaning up installed gems...
Attempting to uninstall rubygems-update-1.8.6
Successfully uninstalled rubygems-update-1.8.6
ERROR:  While executing gem ... (ArgumentError)
    wrong number of arguments (3 for 2)

Please, note that the gem seems to be uninstalled correctly.

My environment, if it may help in any way:

RubyGems Environment:
  - RUBYGEMS VERSION: 1.8.7
  - RUBY VERSION: 1.8.7 (2009-06-12 patchlevel 174) [universal-darwin10.0]
  - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8
  - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-darwin-10
  - GEM PATHS:
     - /Library/Ruby/Gems/1.8
     - /Users/emanuele/.gem/ruby/1.8
     - /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/
@MindTooth

Happens to me as well :/ What can cause this?

@optikfluffel

Here as well =/

@zenspider zenspider was assigned
@zenspider

Fixed

@zenspider zenspider closed this
@tenderlove tenderlove pushed a commit to tenderlove/rubygems that referenced this issue
@zenspider zenspider - Gem.use_paths splatted to take multiple paths! Fixes #148 38e4284
@ttrocks

This issue is still reproducible with 1.8.9

c:\>gem cleanup
Cleaning up installed gems...
Attempting to uninstall rack-test-0.5.7

You have requested to uninstall the gem:
        rack-test-0.5.7
actionpack-3.0.10 depends on [rack-test (~> 0.5.7)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn]  n
Unable to uninstall rack-test-0.5.7:
        Gem::DependencyRemovalException: Uninstallation aborted due to dependent
 gem(s)
Attempting to uninstall rack-mount-0.6.14
Unable to uninstall rack-mount-0.6.14:
        Gem::InstallError: gem "rack-mount" is not installed
Attempting to uninstall rack-1.2.2
Unable to uninstall rack-1.2.2:
        Gem::InstallError: gem "rack" is not installed
Attempting to uninstall mail-2.2.19
Unable to uninstall mail-2.2.19:
        Gem::InstallError: gem "mail" is not installed
Attempting to uninstall i18n-0.5.0
Unable to uninstall i18n-0.5.0:
        Gem::InstallError: gem "i18n" is not installed
Attempting to uninstall erubis-2.6.6
Unable to uninstall erubis-2.6.6:
        Gem::InstallError: gem "erubis" is not installed
Attempting to uninstall builder-2.1.2
Unable to uninstall builder-2.1.2:
        Gem::InstallError: gem "builder" is not installed
Attempting to uninstall arel-2.0.10
Unable to uninstall arel-2.0.10:
        Gem::InstallError: gem "arel" is not installed
Clean Up Complete

My gem list

c:\>gem list

*** LOCAL GEMS ***

abstract (1.0.0)
actionmailer (3.0.10)
actionpack (3.0.10)
activemodel (3.0.10)
activerecord (3.0.10)
activeresource (3.0.10)
activesupport (3.0.10)
archive-tar-minitar (0.5.2)
arel (2.2.1, 2.0.10)
builder (3.0.0, 2.1.2)
bundler (1.0.18)
columnize (0.3.4)
commonwatir (2.0.1)
erubis (2.7.0, 2.6.6)
ffi (1.0.9 x86-mingw32)
firewatir (1.9.3)
hoe (2.12.0)
i18n (0.6.0, 0.5.0)
linecache19 (0.5.12)
mail (2.3.0, 2.2.19)
mime-types (1.16)
minitest (2.5.0)
nokogiri (1.5.0 x86-mingw32)
polyglot (0.3.2)
rack (1.3.2, 1.2.2)
rack-mount (0.8.2, 0.6.14)
rack-test (0.6.1, 0.5.7)
rails (3.0.10)
railties (3.0.10)
rake (0.9.2)
rautomation (0.6.3)
rdiscount (1.6.8)
rdoc (3.9.2)
ruby-debug-base19 (0.11.25)
ruby-debug-base19x (0.11.29)
ruby-debug-ide (0.4.16)
ruby_core_source (0.1.5)
s4t-utils (1.0.4)
thor (0.14.6)
treetop (1.4.10)
tzinfo (0.3.29)
user-choices (1.1.6.1)
watir (2.0.1)
win32-api (1.4.8 x86-mingw32)
win32-process (0.6.5)
windows-api (0.4.0)
windows-pr (1.2.0)
wxruby (2.0.1 x86-mingw32)
xml-simple (1.1.0)
@optikfluffel

same thing here on os x again =/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.