Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Error Message Incorrectly Suggests “gem keys” Command #183

Closed
rue opened this Issue Sep 12, 2011 · 0 comments

Comments

Projects
None yet
3 participants

rue commented Sep 12, 2011

From lib/rubygems/gemcutter_utilities.rb:75, alert_error "No such API key. You can add it with gem keys --add #{key}". There doesn't seem to be such a command.

I'm not quite sure how one is supposed to manage the API keys in .gem/credentials, so unfortunately I can't offer a patch (unless someone can point me to an overview of how it's all supposed to work…)

@qrush qrush was assigned Sep 22, 2011

@evanphx evanphx closed this in 2df50d8 Oct 7, 2012

@nobu nobu pushed a commit to nobu/rubygems that referenced this issue Jan 12, 2014

@brixen brixen Merge pull request #183 from modcloth/more-dash-d-specs
Adding more assertions for the "-d" flag
c8eb3e0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment