Skip to content

Loading…

ruby-gems 2.0.5 breaks gem install rmagick on Windows #599

Closed
criesbeck opened this Issue · 2 comments

2 participants

@criesbeck

On my Windows XP machine and another person's Windows System 7 machine, if gem -v is 2.0.5, then gem install rmagick will fail at link time with "...mingw32/bin/ld.exe: cannot find -lmsvcrt-ruby191".

If we do gem update --system 1.8.24 then gem install rmagick completes successfully.

@drbrain
RubyGems member

Duplicate of #594

@drbrain drbrain closed this
@criesbeck
@drbrain drbrain added a commit that referenced this issue
@drbrain drbrain Fix extension building on Ruby 1.9.3 and mingw
Supplying DESTDIR on mingw causes link errors due to reasons I don't
understand (see the related bug).  Now, on 1.9.3, DESTDIR is not
supplied to the make command which prevents the bug.  Ruby 2.0.0 behaves
as before.

Fixes #594, see also duplicate bug #599
8d772eb
@drbrain drbrain added a commit that referenced this issue
@drbrain drbrain Fix extension building on Ruby 1.9.3 and mingw
Supplying DESTDIR on mingw causes link errors due to reasons I don't
understand (see the related bug).  Now, on 1.9.3, DESTDIR is not
supplied to the make command which prevents the bug.  Ruby 2.0.0 behaves
as before.

Fixes #594, see also duplicate bug #599
50e3e94
@drbrain drbrain added a commit that referenced this issue
@drbrain drbrain Fix extension building on Ruby 1.9.3 and mingw
Supplying DESTDIR on mingw causes link errors due to reasons I don't
understand (see the related bug).  Now, on 1.9.3, DESTDIR is not
supplied to the make command which prevents the bug.  Ruby 2.0.0 behaves
as before.

Fixes #594, see also duplicate bug #599
9667d45
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.