Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Unnecessary error about minimum ruby version during gem install. #798

Closed
chriseppstein opened this Issue Jan 22, 2014 · 6 comments

Comments

Projects
None yet
5 participants

Using ruby 1.8.7:

$ gem install listen
Fetching: timers-1.1.0.gem (100%)
Successfully installed timers-1.1.0
Fetching: celluloid-0.15.2.gem (100%)
ERROR:  Error installing listen:
    celluloid requires Ruby version >= 1.9.2.

Ruby 1.8.7 has not been supported since listen version 1.3.1. So using 1.8.7 that is the version that I should get when I install.

The issue here is that sass wants to support ruby 1.8.7 because that's still the default on a lot of system ruby installs but we also want to allow people to use new versions of this dependency on their new rubies if that's what they have. But if we relax our dependency requirements, the users of sass (who are not rubyists) will not be able to install sass onto 1.8.7 without specifying a version explicitly. It seems like rubygems has all the information to make this decision correctly instead of giving an error here.

Owner

drbrain commented Jan 22, 2014

The RubyGems indexes don't at present contain the required_ruby_version or required_rubygems_version constraints. The work by @indirect on a new index format should have these constraints included so we can correctly install listen on ruby 1.8.7.

@drbrain Thanks, that's great news. So just a change on the server will allow it to work correctly for 1.8.7 and greater? @indirect is there a timeline on when this might land? do you need any help? We'd rather help get this working the right way than vendor this dependency in our gem.

Owner

indirect commented Jan 23, 2014

There is working server and client-side code, it just needs to be integrated and released. I'm currently working my way through several Bundler releases, if which the new index is the last. Almost done with 2 of 4 right now. :)

On Wed, Jan 22, 2014 at 2:33 PM, Chris Eppstein notifications@github.com
wrote:

@drbrain Thanks, that's great news. So just a change on the server will allow it to work correctly for 1.8.7 and greater? @indirect is there a timeline on when this might land? do you need any help? We'd rather help get this working the right way than vendor this dependency in our gem.

Reply to this email directly or view it on GitHub:
#798 (comment)

@indirect Can you confirm this will fix this issue for existing installs of rubygems in 1.8.7?

Owner

indirect commented Jan 23, 2014

@chriseppstein unfortunately, it's impossible to fix this for existing installs of rubygems. The next step after I release Bundler with new index support is to add support to Rubygems for the new index. At that point, if Rubygems is still compatible with Ruby 1.8, upgrading Rubygems will fix the issue.

@next-mad-hatter next-mad-hatter referenced this issue in leejarvis/slop Jan 13, 2015

Closed

Breaks rubygems on ruby 1.9.3 #158

Contributor

copiousfreetime commented Jan 31, 2016

Closing as this is a ruby 1.8.7 issue and 1.8.7 is deprecated

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment