Permalink
Browse files

Update Gemfile and gemspec to allow JRuby and Rubinius. Add JRuby and…

… Rubinius to .travis.yml
  • Loading branch information...
1 parent 2355f6d commit 57310eb9e3115ccc364a6a68c5ebb9addad3e7fa @petergoldstein petergoldstein committed with radar Dec 15, 2013
Showing with 16 additions and 2 deletions.
  1. +6 −0 .travis.yml
  2. +9 −0 Gemfile
  3. +1 −2 paranoia.gemspec
View
6 .travis.yml
@@ -0,0 +1,6 @@
+language: ruby
+rvm:
+ - 1.9.3
+ - 2.0.0
+ - jruby-19mode
+ - rbx
View
9 Gemfile
@@ -1,4 +1,13 @@
source 'https://rubygems.org'
+gem 'sqlite3', :platforms => [:ruby]
+gem 'activerecord-jdbcsqlite3-adapter', :platforms => [:jruby]
+
+platforms :rbx do
+ gem 'rubysl', '~> 2.0'
+ gem 'rubysl-test-unit'
+ gem 'rubinius-developer_tools'
+end
+
# Specify your gem's dependencies in paranoia.gemspec
gemspec
View
3 paranoia.gemspec
@@ -17,8 +17,7 @@ Gem::Specification.new do |s|
s.add_dependency "activerecord", "~> 4.0"
s.add_development_dependency "bundler", ">= 1.0.0"
- s.add_development_dependency "sqlite3"
- s.add_development_dependency "rake", "0.8.7"
+ s.add_development_dependency "rake"
s.files = `git ls-files`.split("\n")
s.executables = `git ls-files`.split("\n").map{|f| f =~ /^bin\/(.*)/ ? $1 : nil}.compact

0 comments on commit 57310eb

Please sign in to comment.