Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 74 lines (59 sloc) 2.123 kb
3abe6cf @FooBarWidget Add some documenting comments for the MSpec config files.
FooBarWidget authored
1 # Configuration file for Ruby 1.8-compatible Ruby implementations.
2 #
3 # Unless you passed to --config (or -B) to MSpec, MSpec will automatically
4 # use this config file if the Ruby interpreter with which MSpec advertises
5 # itself with RUBY_VERSION =~ /1.8/
6
8b35254 @brixen Added config files for 1.8 and 1.9.
brixen authored
7 class MSpecScript
90d7026 @brixen Updated version specific config files with new spec collections.
brixen authored
8 # Language features specs
9 set :language, [ 'language' ]
10
11 # Core library specs
d370c37 @brixen Exclude BasicObject specs on 1.8.x.
brixen authored
12 set :core, [
13 'core',
14
15 # 1.9
16 '^core/basicobject'
17 ]
90d7026 @brixen Updated version specific config files with new spec collections.
brixen authored
18
19 # Standard library specs
20 set :library, [
fe82368 @brixen Removed separate 1.8 directory and moved specs up.
brixen authored
21 'library',
eaa6bba @yugui Excludes imcompatible libraries between 1.8 and 1.9 when verifying specs...
yugui authored
22
23 # 1.9 feature
24 '^library/cmath',
25 '^library/coverage',
26 '^library/json',
27 '^library/minitest',
28 '^library/prime',
29 '^library/ripper',
30 '^library/rake',
31 '^library/rubygems',
8b35254 @brixen Added config files for 1.8 and 1.9.
brixen authored
32 ]
33
90d7026 @brixen Updated version specific config files with new spec collections.
brixen authored
34 # An ordered list of the directories containing specs to run
35 set :files, get(:language) + get(:core) + get(:library)
36
f75c8d9 @nicksieger Adding :ci_files -- mspec-ci won't run for me w/o this change?
nicksieger authored
37 # This set of files is run by mspec ci
38 set :ci_files, get(:files)
39
1ee7bbd @alloy Added :ffi and :optional (which at some point could contain more optiona...
alloy authored
40 # Optional library specs
41 set :ffi, 'optional/ffi'
42
43 # A list of _all_ optional library specs
44 set :optional, [get(:ffi)]
45
46 # The default implementation to run the specs
8b35254 @brixen Added config files for 1.8 and 1.9.
brixen authored
47 set :target, 'ruby'
5a231c3 @runpaint Teach mspec about 1.8 tags.
runpaint authored
48
49 set :tags_patterns, [
50 [%r(language/), 'tags/1.8/language/'],
51 [%r(core/), 'tags/1.8/core/'],
52 [%r(command_line/), 'tags/1.8/command_line/'],
53 [%r(library/), 'tags/1.8/library/'],
54 [/_spec.rb$/, '_tags.txt']
55 ]
aa89ef2 @brixen Enable features for 1.8 and 1.9 configurations.
brixen authored
56
57 # Enable features
58 MSpec.enable_feature :continuation
59 MSpec.enable_feature :fork
8bce8ee @brixen Added :encoding_transition feature for 1.8.7+.
brixen authored
60
9fc440b @brixen Added with_feature guards for Readline specs.
brixen authored
61 # The Readline specs are not enabled by default because the functionality
62 # depends heavily on the underlying library, including whether certain
63 # methods are implemented or not. This makes it extremely difficult to
64 # make the specs consistently pass. Until a suitable scheme to handle
65 # all these issues, the specs will not be enabled by default.
66 #
67 # MSpec.enable_feature :readline
68
8bce8ee @brixen Added :encoding_transition feature for 1.8.7+.
brixen authored
69 if SpecVersion.new(RUBY_VERSION) >= "1.8.7"
70 # These are encoding-aware methods backported to 1.8.7+ (eg String#bytes)
71 MSpec.enable_feature :encoding_transition
72 end
8b35254 @brixen Added config files for 1.8 and 1.9.
brixen authored
73 end
Something went wrong with that request. Please try again.