Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

How to manage Elasticsearch 7.x? #1649

Closed
eostis opened this issue Aug 9, 2019 · 5 comments

Comments

@eostis
Copy link

commented Aug 9, 2019

I tried to follow some threads on Elasticsearch 7.x, and noticed a recent commit for 7.1

But is there any documentation/hint/examples on that subject anywhere?

@eostis

This comment has been minimized.

Copy link
Author

commented Aug 10, 2019

I installed the latest commit, and managed to create an ES 7.3 index.

But ES 6.x indexes can no more be created, as the code automatically sends the parameter 'include_type_name' (not whitelisted in ES 6.x versions):

/vendor/ruflin/elastica/lib/Elastica/Index.php:

 public function requestEndpoint(AbstractEndpoint $endpoint)
    {
        $cloned = clone $endpoint;

        $cloned->setIndex($this->getName());
        if ($endpoint instanceof Create || $endpoint instanceof \Elasticsearch\Endpoints\Indices\Mapping\Put) {
            $cloned->setParams(['include_type_name' => true]);
        }

        return $this->getClient()->requestEndpoint($cloned);
    }

@p365labs

This comment has been minimized.

Copy link
Collaborator

commented Aug 12, 2019

If u use the 7.x branch or the master one, the ES supported version is 7. If u want to use or work with a older version have a look at our version matrix

@eostis

This comment has been minimized.

Copy link
Author

commented Aug 20, 2019

I did use the master branch indeed (I could not find a 7.x branch).

Does that mean Elastica will not be retro-compatible with versions prior to 7.x?

@ruflin

This comment has been minimized.

Copy link
Owner

commented Aug 22, 2019

We didn't create a 7.x branch yet but master is the one compatible with 7. Do be compatible with older versions, you need to download the 6.x releases.

@eostis

This comment has been minimized.

Copy link
Author

commented Aug 22, 2019

Thanks.

@eostis eostis closed this Aug 22, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.