Fix direct generators deprecation errors #1282

Merged
merged 1 commit into from Apr 6, 2017

Conversation

Projects
None yet
2 participants
@nicklaw5
Contributor

nicklaw5 commented Apr 5, 2017

Deprecation of the below is now enforced in 5.3

  • "prefix_len" becomes "prefix_length"
  • "min_word_len" becomes "min_word_length"

Docs: https://www.elastic.co/guide/en/elasticsearch/reference/current/search-suggesters-phrase.html#_direct_generators

nicklaw5 added a commit to ramuss/FazlandElasticaBundle that referenced this pull request Apr 5, 2017

@ruflin

This comment has been minimized.

Show comment
Hide comment
@ruflin

ruflin Apr 5, 2017

Owner

Thanks for the change. LGTM. Could you update the CHANGELOG.md?

Owner

ruflin commented Apr 5, 2017

Thanks for the change. LGTM. Could you update the CHANGELOG.md?

Fix DirectGenerator deprecation errors
Deprecation of the below is now enforced in 5.3

- "prefix_len" becomes "prefix_length"
- "min_word_len" becomes "min_word_length"
@nicklaw5

This comment has been minimized.

Show comment
Hide comment
@nicklaw5

nicklaw5 Apr 5, 2017

Contributor

@ruflin changelog has been updated.

Contributor

nicklaw5 commented Apr 5, 2017

@ruflin changelog has been updated.

@ruflin ruflin merged commit e0991ce into ruflin:master Apr 6, 2017

2 of 3 checks passed

codecov/patch 0% of diff hit (target 84.31%)
Details
codecov/project 84.31% remains the same compared to ab9b69b
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@ruflin

This comment has been minimized.

Show comment
Hide comment
@ruflin

ruflin Apr 6, 2017

Owner

@nicklaw5 Thanks, merged.

Owner

ruflin commented Apr 6, 2017

@nicklaw5 Thanks, merged.

@nicklaw5 nicklaw5 deleted the nicklaw5:fix-deprecation-errors-in-5.3 branch Apr 7, 2017

mhernik pushed a commit to mhernik/Elastica that referenced this pull request Jul 24, 2017

Fix DirectGenerator deprecation errors (#1282)
Deprecation of the below is now enforced in 5.3

- "prefix_len" becomes "prefix_length"
- "min_word_len" becomes "min_word_length"
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment