Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RD3 GUI: When displaying overview page with a big amount of projects ( over 15 ) the last ones may not load "configure" and "create job" buttons correctly #4149

Closed
sebastianbello opened this issue Oct 23, 2018 · 6 comments

Comments

@sebastianbello
Copy link

commented Oct 23, 2018

Describe the bug
The "Projects" overview page may not display correctly the interface buttons ,"configure" and "create job", for the last projects in the list.

My Rundeck detail

  • Rundeck version: 3.0.7
  • install type: WAR

To Reproduce

  1. Log into a Rundeck instance with over 15 projects

  2. Click on "Home" to list all the Projects

  3. After a while ( "spinning wheels" icon) projects load into visible window

  4. Scroll down to display more projects, "spinning wheels" persist not loading "configure" and "create job" buttons correctly

Expected behavior
After scrolling to see the remaining projects, the remaining projects should load the buttons initially outside of the viewport.

Screenshots
Chrome
image

Firefox
image

Internet Explorer
image

Microsoft Edge
image

Desktop (please complete the following information):

  • OS: Linux , Windows
  • Browser: Firefox, Chrome, IE, Edge

Additional context
As a "workaround" zooming out and back in usually displays the elements correctly.

@mazzella-c

This comment has been minimized.

Copy link

commented Oct 24, 2018

Same issue here.

@mergeable

This comment has been minimized.

Copy link

commented Jan 20, 2019

There haven't been much activity here. This is stale. Is it still relevant? This is a friendly reminder to please resolve it. :-)

@mazzella-c

This comment has been minimized.

Copy link

commented Jan 21, 2019

Still relevant on 3.0.11.

@benruset

This comment has been minimized.

Copy link

commented Mar 12, 2019

Happening on 3.0.16, too. I have 30 projects. Only the first 12 projects fully load - everything else just sits and spins until I zoom in and out. Using MacOS Mojave with Safari and Firefox.

I don't know if it matters but I am terminating SSL on an AWS internal ELB for my Rundeck instance.

@beakerman29

This comment has been minimized.

Copy link

commented Jun 3, 2019

I can confirm it is still an issue on 3.0.20 as well. I have 30 projects as well

@sebastianbello

This comment has been minimized.

Copy link
Author

commented Jun 18, 2019

Behavior persists in 3.1 RC1

image

@gschueler gschueler added this to the 3.1.0-RC2 milestone Jun 18, 2019

gschueler added a commit that referenced this issue Jun 18, 2019

gschueler added a commit that referenced this issue Jun 19, 2019

Merge pull request #4977 from rundeck/issue/4149
Fix home page project ui not loading #4149

gschueler added a commit that referenced this issue Jun 19, 2019

Merge pull request #4978 from rundeck/issue/4149-backport
[3.0.x backport] fix #4149 correctly trigger project ui loading
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.