Skip to content
Browse files

Add provision for creating jruby-compatible gem

  • Loading branch information...
1 parent bf34362 commit 5d55823429867a8bc501a6096debd37184b605d0 @pjhyett pjhyett committed Apr 3, 2010
Showing with 8 additions and 3 deletions.
  1. +8 −3 Rakefile
View
11 Rakefile
@@ -11,9 +11,14 @@ begin
gem.homepage = "http://github.com/mojombo/bert"
gem.authors = ["Tom Preston-Werner"]
gem.add_development_dependency("thoughtbot-shoulda")
- gem.require_paths = ["lib", "ext"]
- gem.files.include("ext")
- gem.extensions << 'ext/bert/c/extconf.rb'
+ if ENV["JAVA"]
+ gem.extensions = nil
+ gem.platform = 'java'
+ else
+ gem.require_paths = ["lib", "ext"]
+ gem.files.include("ext")
+ gem.extensions << 'ext/bert/c/extconf.rb'
+ end
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
rescue LoadError

0 comments on commit 5d55823

Please sign in to comment.
Something went wrong with that request. Please try again.