Permalink
Browse files

switch to coffeescript 1.7, which is NOT BACKWARDS COMPATIBLE with 1.…

…6 despite the semver.
  • Loading branch information...
russellmcc committed Feb 6, 2014
1 parent 424d540 commit 79a69b76c30f1fa621479490c70cbfa190d63b8a
Showing with 6 additions and 6 deletions.
  1. +2 −2 Cakefile
  2. +1 −1 lib/index.js
  3. +1 −1 lib/osc-utilities.coffee
  4. +2 −2 package.json
View
@@ -3,14 +3,14 @@ child = require 'child_process'
task 'test', 'run tests (requires development install)', (options) ->
process.env['NODE_PATH'] = './lib/:$NODE_PATH'
- test = child.spawn 'mocha', ['--compilers', 'coffee:coffee-script', '-u', 'tdd', 'test']
+ test = child.spawn 'mocha', ['--compilers', 'coffee:coffee-script/register', '-u', 'tdd', 'test']
test.stdout.pipe process.stdout
test.stderr.pipe process.stderr
test.on 'exit', (num) ->
return process.exit num
spawnMochaCov = (reporter) ->
- return child.spawn 'mocha', ['--compilers', 'coffee:coffee-script', '-r', 'blanket', '-R', reporter, '-u', 'tdd', 'test']
+ return child.spawn 'mocha', ['--compilers', 'coffee:coffee-script/register', '-r', 'blanket', '-R', reporter, '-u', 'tdd', 'test']
task 'coverage', 'run tests with coverage check (requires development install)', (options) ->
process.env['NODE_PATH'] = './lib/:$NODE_PATH'
View
@@ -91,7 +91,7 @@
// [spec]: http://opensoundcontrol.org/spec-1_0
var utils, coffee;
- coffee = require("coffee-script");
+ require("coffee-script/register");
utils = require("./osc-utilities");
// ~api~
//## Exported functions
View
@@ -4,7 +4,7 @@
# My guess is client code won't need this. If you do need this, you must
# require coffee first, then write:
#
-# require("coffee-script");
+# require("coffee-script/register");
# osc-utils = require("osc/lib/osc-utilities");
#
# See the comments in osc.coffee for more information about the structure of
View
@@ -1,6 +1,6 @@
{
"name": "osc-min",
- "version": "0.0.13",
+ "version": "0.0.14",
"main": "lib/index",
"author": {
"name": "Russell McClellan",
@@ -20,7 +20,7 @@
},
"dependencies": {
"binpack": "*",
- "coffee-script": ">=1.3.0"
+ "coffee-script": "^1.7"
},
"devDependencies": {
"mocha": "*",

0 comments on commit 79a69b7

Please sign in to comment.