Skip to content
Permalink
Browse files

Use xcode 9.3 on all osx builders

  • Loading branch information...
alexcrichton committed May 21, 2019
1 parent beea4f5 commit 78965f49c8f730327240f59ed0eae4e007f0a0ea
Showing with 4 additions and 1 deletion.
  1. +4 −1 .azure-pipelines/steps/run.yml
@@ -35,11 +35,14 @@ steps:
displayName: Install build dependencies (OSX)
condition: and(succeeded(), eq(variables['Agent.OS'], 'Darwin'), eq(variables['RUST_CHECK_TARGET'],'dist'))

# Switch to XCode 9.3 on OSX since it seems to be the last version that supports
# i686-apple-darwin. We'll eventually want to upgrade this and it will probably
# force us to drop i686-apple-darwin, but let's keep the wheels turning for now.
- bash: |
set -e
sudo xcode-select --switch /Applications/Xcode_9.3.app
displayName: Switch to Xcode 9.3 (OSX)
condition: and(succeeded(), eq(variables['Agent.OS'], 'Darwin'), eq(variables['RUST_CHECK_TARGET'],'dist'))
condition: and(succeeded(), eq(variables['Agent.OS'], 'Darwin'))

- template: install-windows-build-deps.yml

0 comments on commit 78965f4

Please sign in to comment.
You can’t perform that action at this time.