Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Mention editions when emitting 2015 exclusive errors #61914

Open
estebank opened this issue Jun 17, 2019 · 0 comments

Comments

@estebank
Copy link
Contributor

commented Jun 17, 2019

The difference between edition defaults for new projects between cargo and rustc can lead to confusion, particularly for newcomers. All errors that would only happen on one edition should mention the discrepancy. We made an effort to have lints for 2015 to 2018 migration, but we were more lax on clarifying diagnostics when following 2018 guides when rustc is ran under 2015. Things like nll discrepancies (seen in #61855, moot point once we enable nll in 2015) come to mind, while things like let async = 6; (pass in 2015, "error: expected pattern, found reserved keyword async" without any mention of editions in 2018) which do not mention editions at all (it should recommend using r#raw_idents always, explain it was accepted in 2015 edition but it's being run in 2018).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.