Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add pkg-config to dependency list if building for Linux on Linux #64884

Merged
merged 2 commits into from Sep 29, 2019

Conversation

@jakevossen5
Copy link
Contributor

jakevossen5 commented Sep 28, 2019

I got this message when building from source on Ubuntu:

It looks like you're compiling on Linux and also targeting Linux. Currently this
requires the `pkg-config` utility to find OpenSSL but unfortunately `pkg-config`
could not be found. If you have OpenSSL installed you can likely fix this by
installing `pkg-config`.

I feel like it would be a better experience to show this in the dependencies instead of having to run into this issue.

jakevossen5 added 2 commits Sep 28, 2019
@rust-highfive

This comment has been minimized.

Copy link
Collaborator

rust-highfive commented Sep 28, 2019

Thanks for the pull request, and welcome! The Rust team is excited to review your changes, and you should hear from @alexcrichton (or someone else) soon.

If any changes to this PR are deemed necessary, please add them as extra commits. This ensures that the reviewer can see what has changed since they last reviewed the code. Due to the way GitHub handles out-of-date commits, this should also make it reasonably obvious what issues have or haven't been addressed. Large or tricky changes may require several passes of review and changes.

Please see the contribution instructions for more information.

@Mark-Simulacrum

This comment has been minimized.

Copy link
Member

Mark-Simulacrum commented Sep 29, 2019

@bors r+ rollup

@bors

This comment has been minimized.

Copy link
Contributor

bors commented Sep 29, 2019

📌 Commit ea347b6 has been approved by Mark-Simulacrum

Centril added a commit to Centril/rust that referenced this pull request Sep 29, 2019
Add pkg-config to dependency list if building for Linux on Linux

I got this message when building from source on Ubuntu:

```
It looks like you're compiling on Linux and also targeting Linux. Currently this
requires the `pkg-config` utility to find OpenSSL but unfortunately `pkg-config`
could not be found. If you have OpenSSL installed you can likely fix this by
installing `pkg-config`.
```

I feel like it would be a better experience to show this in the dependencies instead of having to run into this issue.
bors added a commit that referenced this pull request Sep 29, 2019
Rollup of 5 pull requests

Successful merges:

 - #63492 (Remove redundancy from the implementation of C variadics.)
 - #64589 (Differentiate AArch64 bare-metal targets between hf and non-hf.)
 - #64799 (Fix double panic when printing query stack during an ICE)
 - #64824 (No StableHasherResult everywhere)
 - #64884 (Add pkg-config to dependency list if building for Linux on Linux)

Failed merges:

r? @ghost
@bors bors merged commit ea347b6 into rust-lang:master Sep 29, 2019
4 checks passed
4 checks passed
pr Build #20190928.70 succeeded
Details
pr (Linux mingw-check) Linux mingw-check succeeded
Details
pr (Linux x86_64-gnu-llvm-6.0) Linux x86_64-gnu-llvm-6.0 succeeded
Details
pr (LinuxTools) LinuxTools succeeded
Details
@jakevossen5 jakevossen5 referenced this pull request Sep 29, 2019
Centril added a commit to Centril/rust that referenced this pull request Sep 29, 2019
fixed typo

Accidentally had a typo in rust-lang#64884, sorry!
Centril added a commit to Centril/rust that referenced this pull request Sep 29, 2019
fixed typo

Accidentally had a typo in rust-lang#64884, sorry!
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.