Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Exec resources require fully qualified paths #1

Merged
merged 1 commit into from

2 participants

@adamstrawson

In Puppet Enterprise 2.7.2, exec resources require either fully qualified paths or a path in which to look for the executable.

Otherwise you receive the following error;

Failed to apply catalog: 'pip install glances' is not qualified and no path was specified. Please qualify the command or specify a path.

Added the path resource fixes this.

@rverchere rverchere merged commit c18210c into rverchere:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Mar 25, 2013
  1. @adamstrawson

    Added path as Exec resources require either fully qualified paths or …

    adamstrawson authored
    …a path in which to look for the executable
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 0 deletions.
  1. +1 −0  manifests/init.pp
View
1  manifests/init.pp
@@ -40,6 +40,7 @@
ensure => installed,
}
exec { 'pip-glances':
+ path => '/usr/bin:/bin:/usr/sbin:/sbin',
command => 'pip install glances',
creates => '/usr/local/bin/glances',
require => Package['python-pip'],
Something went wrong with that request. Please try again.