has failures when run manually #19

aspiers opened this Issue Aug 23, 2013 · 3 comments


None yet

2 participants

@aspiers has failures when I run it manually:

$ tf --text fast/
##### starting test do.
$ source "$rvm_path/scripts/rvm"
$ rvm use 1.8.7 --install
Using /home/adam/.rvm/gems/ruby-1.8.7-p374
# passed: status = 0
$ rvm gemset create test1
gemset created test1    => /home/adam/.rvm/gems/ruby-1.8.7-p374@test1
# passed: status = 0
$ rvm gemset create test2
gemset created test2    => /home/adam/.rvm/gems/ruby-1.8.7-p374@test2
# passed: status = 0
$ : do
$ rvm 9.9.9 do rvm gemdir
Unknown ruby interpreter version: '9.9.9'.
Ruby  is not installed.
# passed: status = 1
# passed: match = /is not installed/
$ rvm 1.8.7 do rvm gemdir
/home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/spec_set.rb:92:in `materialize': Could not find fattr-2.2.1 in any of the sources (Bundler::GemNotFound)
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/spec_set.rb:85:in `map!'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/spec_set.rb:85:in `materialize'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/definition.rb:114:in `specs'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/definition.rb:159:in `specs_for'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/definition.rb:148:in `requested_specs'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/environment.rb:18:in `requested_specs'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/runtime.rb:13:in `setup'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler.rb:120:in `setup'
        from /home/adam/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.4/lib/bundler/setup.rb:17# failed: status = 0 # was 1
# failed: match = /1.8.7-p[[:digit:]]+/
Ruby enVironment Manager member

it is required to disable rubygems-bundler for the tests:

NOEXEC_DISABLE=1 tf --text fast/

unfortunately because we test on already running rvm some tests require extra configuration and might need something like removing ~/.rvmrc (I had it last time)


Ah! So please update

Ruby enVironment Manager member

fixed with rvm/rvm@37dbad1

@mpapis mpapis closed this Aug 23, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment