Permalink
Browse files

Merge branch 'hotfix/1.17.10' into stable

  • Loading branch information...
mpapis committed Jan 19, 2013
2 parents 70a0a62 + 81a9905 commit 0ddddc164dc4fb9860e95f1b42b8b147daa48518
Showing with 217 additions and 159 deletions.
  1. +1 −1 VERSION
  2. +9 −9 config/db
  3. +3 −2 config/known
  4. +109 −87 config/md5
  5. +17 −0 config/remote
  6. +27 −10 config/sha512
  7. +18 −0 patches/ruby/1.9.3/p374/ruby-multilib.patch
  8. +7 −2 scripts/functions/manage/ruby
  9. +3 −33 scripts/selector
  10. +5 −15 scripts/upgrade
  11. +18 −0 update-remote.sh
View
@@ -1 +1 @@
-1.17.9
+1.17.10
View
@@ -2,9 +2,8 @@
niceness=0
# Rubies
interpreter=ruby
-ruby_version=1.9.3
+default_ruby=ruby
ruby_configure_flags=--enable-shared --disable-install-doc
-ruby_patchlevel=362
ruby_configure=--enable-shared
tcs_repo_url=git://github.com/thecodeshop/ruby.git
tcs_repo_branch=trunk
@@ -21,13 +20,14 @@ ruby_1.7_url=http://ftp.ruby-lang.org/pub/ruby/1.7
ruby_1.8_url=http://ftp.ruby-lang.org/pub/ruby/1.8
ruby_1.9_url=http://ftp.ruby-lang.org/pub/ruby/1.9
ruby_2.0_url=http://ftp.ruby-lang.org/pub/ruby/2.0
-ruby_2.0.0_patch_level=review2
-ruby_1.9.3_patch_level=362
-ruby_1.9.2_patch_level=320
-ruby_1.9.1_patch_level=431
-ruby_1.8.7_patch_level=371
-ruby_1.8.6_patch_level=420
-ruby_1.8.5_patch_level=231
+ruby_version=1.9.3
+ruby_2.0.0_patch_level=rc1
+ruby_1.9.3_patch_level=p374
+ruby_1.9.2_patch_level=p320
+ruby_1.9.1_patch_level=p431
+ruby_1.8.7_patch_level=p371
+ruby_1.8.6_patch_level=p420
+ruby_1.8.5_patch_level=p231
rubygems_url=http://production.cf.rubygems.org/rubygems
rubygems_repo_url=git://github.com/rubygems/rubygems.git
rubygems_version=latest-1.8
View
@@ -7,9 +7,10 @@
[ruby-]1.9.3-p194
[ruby-]1.9.3-p286
[ruby-]1.9.3-p327
-[ruby-]1.9.3[-p362]
+[ruby-]1.9.3-p362
+[ruby-]1.9.3[-p374]
[ruby-]1.9.3-head
-[ruby-]2.0.0-preview2
+[ruby-]2.0.0-rc1
ruby-head
# GoRuby
View

Large diffs are not rendered by default.

Oops, something went wrong.
View
@@ -1,9 +1,11 @@
https://rvm.io/binaries/arch/libc-2.15/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/arch/libc-2.15/x86_64/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/arch/libc-2.15/x86_64/ruby-1.9.3-p327.tar.bz2
+https://rvm.io/binaries/arch/libc-2.15/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/centos/5.6/x86_64/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/centos/5.6/x86_64/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/centos/5.6/x86_64/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/centos/5.6/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/centos/5.6/x86_64/ruby-2.0.0-rc1.tar.bz2
https://rvm.io/binaries/centos/6.3/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/centos/6.3/x86_64/ruby-1.9.3-p286.tar.bz2
@@ -14,40 +16,55 @@ https://rvm.io/binaries/debian/6.0.4/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/debian/6.0.4/x86_64/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/debian/6.0.4/x86_64/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/debian/6.0.4/x86_64/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/debian/6.0.4/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/debian/6.0.4/x86_64/ruby-2.0.0-rc1.tar.bz2
https://rvm.io/binaries/debian/wheezy_sid/armv6l/ruby-1.9.3-p362.tar.bz2
https://rvm.io/binaries/debian/wheezy_sid/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/debian/wheezy_sid/x86_64/ruby-1.9.3-p286.tar.bz2
+https://rvm.io/binaries/debian/wheezy_sid/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/opensuse/12.1/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/opensuse/12.1/x86_64/ruby-1.9.3-p286.tar.bz2
+https://rvm.io/binaries/opensuse/12.1/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/opensuse/12.2/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/opensuse/12.2/x86_64/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/opensuse/12.2/x86_64/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/opensuse/12.2/x86_64/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/opensuse/12.2/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/opensuse/12.2/x86_64/ruby-2.0.0-rc1.tar.bz2
https://rvm.io/binaries/osx/10.8/x86_64/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/i386/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/i386/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/i386/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/i386/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/ubuntu/10.04/i386/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/i386/ruby-2.0.0-rc1.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/x86_64/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/x86_64/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/x86_64/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/ubuntu/10.04/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/ubuntu/10.04/x86_64/ruby-2.0.0-rc1.tar.bz2
https://rvm.io/binaries/ubuntu/11.10/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/ubuntu/11.10/x86_64/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/ubuntu/11.10/x86_64/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/ubuntu/11.10/x86_64/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/ubuntu/11.10/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/ubuntu/11.10/x86_64/ruby-2.0.0-rc1.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/i386/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/i386/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/i386/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/i386/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/ubuntu/12.04/i386/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/i386/ruby-2.0.0-rc1.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/x86_64/ruby-1.9.3-p286.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/x86_64/ruby-1.9.3-p327.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/x86_64/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/ubuntu/12.04/x86_64/ruby-1.9.3-p374.tar.bz2
https://rvm.io/binaries/ubuntu/12.04/x86_64/ruby-2.0.0-rc1.tar.bz2
+https://rvm.io/binaries/ubuntu/12.10/x86_64/ruby-1.9.3-p194.tar.bz2
+https://rvm.io/binaries/ubuntu/12.10/x86_64/ruby-1.9.3-p286.tar.bz2
+https://rvm.io/binaries/ubuntu/12.10/x86_64/ruby-1.9.3-p327.tar.bz2
+https://rvm.io/binaries/ubuntu/12.10/x86_64/ruby-1.9.3-p362.tar.bz2
+https://rvm.io/binaries/ubuntu/12.10/x86_64/ruby-1.9.3-p374.tar.bz2
+https://rvm.io/binaries/ubuntu/12.10/x86_64/ruby-2.0.0-rc1.tar.bz2
Oops, something went wrong.

0 comments on commit 0ddddc1

Please sign in to comment.