Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Updated rvm-prompt tests to run rvm prompt in correct directory. Also…

… updated 1.9.1 and 1.8.6 tests to use the correct 'head' versions
  • Loading branch information...
commit 158c4c81ae4b079eafcec4199582e062c14eef88 1 parent d6d00b1
@workmad3 workmad3 authored wayneeseguin committed
Showing with 23 additions and 20 deletions.
  1. +23 −20 test/rvm/rvm-prompt_test
View
43 test/rvm/rvm-prompt_test
@@ -4,35 +4,38 @@ source ./test/setup
initialize_rvm
-btu_run "prompt=\$(rvm 1.9.1 ; scripts/rvm-prompt)"
-assert string_eq "[ruby-1.9.1-p243]" "$prompt"
+btu_run "prompt=\$(rvm 1.9.1 ; binscripts/rvm-prompt)"
+assert string_eq "ruby-1.9.1-p378" "$prompt"
-btu_run "prompt=\$(rvm 1.9.1-head ; scripts/rvm-prompt)"
-assert string_eq "[ruby-1.9.1-head]" "$prompt"
+btu_run "prompt=\$(rvm 1.9.1-head ; binscripts/rvm-prompt)"
+assert string_eq "ruby-1.9.1-head" "$prompt"
-btu_run "prompt=\$(rvm 1.8.6 ; scripts/rvm-prompt)"
-assert string_eq "[ruby-1.8.6-p383]" "$prompt"
+btu_run "prompt=\$(rvm 1.8.6 ; binscripts/rvm-prompt)"
+assert string_eq "ruby-1.8.6-p399" "$prompt"
-btu_run "prompt=\$(rvm ree ; scripts/rvm-prompt)"
-assert string_eq "[ree-1.8.7-2009.10]" "$prompt"
+btu_run "prompt=\$(rvm ree ; binscripts/rvm-prompt)"
+assert string_eq "ree-1.8.7-2009.10" "$prompt"
-btu_run "prompt=\$(rvm ree ; ./scripts/rvm-prompt i)"
-assert "string_eq" "[ree]" "$prompt"
+btu_run "prompt=\$(rvm ree ; binscripts/rvm-prompt i)"
+assert string_eq "ree" "$prompt"
-btu_run "prompt=\$(rvm ree ; ./scripts/rvm-prompt i v)"
-assert "string_eq" "[ree-1.8.7]" "$prompt"
+btu_run "prompt=\$(rvm ree ; binscripts/rvm-prompt i v)"
+assert string_eq "ree-1.8.7" "$prompt"
-btu_run "prompt=\$(rvm ree ; ./scripts/rvm-prompt v)"
-assert "string_eq" "[1.8.7]" "$prompt"
+btu_run "prompt=\$(rvm ree ; binscripts/rvm-prompt v)"
+assert string_eq "1.8.7" "$prompt"
-btu_run "prompt=\$(rvm ree ; ./scripts/rvm-prompt v p)"
-assert "string_eq" "[1.8.7-2009.10]" "$prompt"
+btu_run "prompt=\$(rvm ree ; binscripts/rvm-prompt v p)"
+assert string_eq "1.8.7-2009.10" "$prompt"
-btu_run "prompt=\$(rvm ree-head ; scripts/rvm-prompt)"
-assert string_eq "[ree-1.8.7-head]" "$prompt"
+btu_run "prompt=\$(rvm ree-head ; binscripts/rvm-prompt)"
+assert string_eq "ree-1.8.7-head" "$prompt"
-btu_run "prompt=\$(rvm 1.9.1 ; scripts/rvm-prompt p v i)"
-assert string_eq "[p243-1.9.1-ruby]" "$prompt"
+btu_run "prompt=\$(rvm 1.9.1 ; binscripts/rvm-prompt p v i)"
+assert string_eq "p378-1.9.1-ruby" "$prompt"
+
+btu_run "prompt=\$(rvm system ; binscripts/rvm-prompt)"
+assert string_eq "system" "$prompt"
if [[ -z "$rvm_teset_suite_flag" ]] ; then btu_summary ; fi
Please sign in to comment.
Something went wrong with that request. Please try again.