Permalink
Browse files

More misc work on fixing the build process, nameling detecting rubies

  • Loading branch information...
1 parent 54f5253 commit 5165defd93290507505613c06e03055ba551b7d2 @Sutto Sutto committed Jul 2, 2010
Showing with 2 additions and 5 deletions.
  1. +1 −1 scripts/manage
  2. +1 −4 scripts/utility
View
@@ -294,7 +294,7 @@ RubyWrapper
PATH=$(echo $PATH | tr ':' '\n' | awk '$0 !~ /rvm/' | paste -sd : -)
PATH=$rvm_bin_path:$PATH ; export PATH
- if [[ ! -z "$(echo $rvm_ruby_version | awk '/^1\.0/')" ]] && [[ -z "$rvm_head_flag" ]] ; then
+ if [[ -n "$(echo $rvm_ruby_version | awk '/^1\.0/')" ]] && [[ -z "$rvm_head_flag" ]] ; then
$rvm_scripts_path/log "info" "Downloading $rvm_ruby_package_file, this may take a while depending on your connection..."
$rvm_scripts_path/fetch "$rvm_url"
result=$? ; if [[ "$result" -gt 0 ]] ; then
View
@@ -205,15 +205,12 @@ __rvm_18_compat_ruby() {
__rvm_ensure_has_18_compat_ruby() {
if [[ -z "$(__rvm_18_compat_ruby)" ]]; then
# TODO: install currently doesn't return the correct status.
- original_ruby="$(__rvm_environment_identifier)"
local compat_result=0
- if ! $rvm_bin_path/rvm install 1.8.7; then
+ if ! ( rvm install 1.8.7 ); then
$rvm_scripts_path/log "fatal" "To proceed rvm requires a 1.8-compatible ruby is installed. We attempted to install 1.8.7 automatically but it failed."
$rvm_scripts_path/log "fatal" "Please install it manually (or a compatible alternative) to proceed."
compat_result=1
fi
- __rvm_unset_ruby_variables
- __rvm_become "$original_ruby"
unset original_ruby
return $compat_result
fi

0 comments on commit 5165def

Please sign in to comment.