Permalink
Browse files

updated the repo from wayneeseguin/rvm to rvm/rvm

  • Loading branch information...
1 parent 93a8c43 commit 92b907537431e9214f5276bbafa2ba1b219dcacf @havenwood havenwood committed Apr 13, 2015
View
@@ -28,7 +28,7 @@ have found out that your problem is not resolved by the documentation then pleas
## Filing
Documentation: https://github.com/rvm/rvm-site/issues/new<br />
-RVM: https://github.com/wayneeseguin/rvm/issues/new
+RVM: https://github.com/rvm/rvm/issues/new
*When in doubt as to whether your issue might relate to another simply file a new bug and
we will mark it as duplicate if it needs to be. It's always better to file a new ticket and
@@ -60,4 +60,4 @@ rvm --debug [command]
Make sure to include all mentioned log files.
## Coding guidelines
-https://github.com/wayneeseguin/rvm/blob/master/FORMATTING.md
+https://github.com/rvm/rvm/blob/master/FORMATTING.md
View
@@ -4,23 +4,23 @@
Note that the [`vboxtest`](docs/vm_tests.md) approach is now outdated.
It's better to use the
-[`rvm-test`](https://github.com/wayneeseguin/rvm-test/) test suite
+[`rvm-test`](https://github.com/rvm/rvm-test/) test suite
which lives in a separate git submodule. (It's separate in order to
allow reuse when hacking on rvm2).
$ git submodule init # Register the rvm-test submodule in .git/config
$ git submodule update # Check out the rvm-test submodule
Now read [`rvm-test`'s
-README.md](https://github.com/wayneeseguin/rvm-test/blob/master/README.md)
+README.md](https://github.com/rvm/rvm-test/blob/master/README.md)
and follow those instructions to make sure you can successfully run
the tests (you will need rvm already installed).
## Set up test installation of rvm
You need a test rvm install to run the test suite against:
- $ git clone https://github.com/wayneeseguin/rvm # or your own github fork
+ $ git clone https://github.com/rvm/rvm # or your own github fork
$ cd rvm
$ rvm switch ~/path/to/rvm/test/install # choose a path here
$ ./install
@@ -44,7 +44,7 @@ To get back to using original rvm installation run:
First write a test for the behaviour you expect. For details on how
to write new tests, see [`rvm-test`'s
-README.md](https://github.com/wayneeseguin/rvm-test/blob/master/README.md).
+README.md](https://github.com/rvm/rvm-test/blob/master/README.md).
Then run the test:
$ NOEXEC_DISABLE=1 tf --text rvm-test/fast/foo_comment_test.sh
@@ -6,7 +6,7 @@ set -o errexit
rvm_install_initialize()
{
- DEFAULT_SOURCES=(github.com/wayneeseguin/rvm bitbucket.org/mpapis/rvm)
+ DEFAULT_SOURCES=(github.com/rvm/rvm bitbucket.org/mpapis/rvm)
BASH_MIN_VERSION="3.2.25"
if
@@ -117,7 +117,7 @@ Options
If account is wayneeseguin or mpapis, installs from one of the following:
- https://github.com/wayneeseguin/rvm/archive/master.tar.gz
+ https://github.com/rvm/rvm/archive/master.tar.gz
https://bitbucket.org/mpapis/rvm/get/master.tar.gz
Otherwise, installs from:
@@ -128,7 +128,7 @@ Options
If account is wayneeseguin or mpapis, installs from one of the following:
- https://github.com/wayneeseguin/rvm/archive/<branch>.tar.gz
+ https://github.com/rvm/rvm/archive/<branch>.tar.gz
https://bitbucket.org/mpapis/rvm/get/<branch>.tar.gz
Otherwise, installs from:
@@ -139,7 +139,7 @@ Options
Installs the branch from one of the following:
- https://github.com/wayneeseguin/rvm/archive/<branch>.tar.gz
+ https://github.com/rvm/rvm/archive/<branch>.tar.gz
https://bitbucket.org/mpapis/rvm/get/<branch>.tar.gz
[--]source <source>
@@ -163,9 +163,9 @@ Options
Provides debug logging for the installation script.
Actions
- master - Installs RVM from the master branch at wayneeseguin/rvm on github or mpapis/rvm
+ master - Installs RVM from the master branch at rvm/rvm on github or mpapis/rvm
on bitbucket.org.
- stable - Installs RVM from the stable branch a wayneeseguin/rvm on github or mpapis/rvm
+ stable - Installs RVM from the stable branch a rvm/rvm on github or mpapis/rvm
on bitbucket.org.
help - Displays this output.
@@ -232,10 +232,10 @@ rvm_is_a_shell_function()
}
# Searches the tags for the highest available version matching a given pattern.
-# fetch_version (github.com/wayneeseguin/rvm bitbucket.org/mpapis/rvm) 1.10. -> 1.10.3
-# fetch_version (github.com/wayneeseguin/rvm bitbucket.org/mpapis/rvm) 1.10. -> 1.10.3
-# fetch_version (github.com/wayneeseguin/rvm bitbucket.org/mpapis/rvm) 1. -> 1.11.0
-# fetch_version (github.com/wayneeseguin/rvm bitbucket.org/mpapis/rvm) "" -> 2.0.1
+# fetch_version (github.com/rvm/rvm bitbucket.org/mpapis/rvm) 1.10. -> 1.10.3
+# fetch_version (github.com/rvm/rvm bitbucket.org/mpapis/rvm) 1.10. -> 1.10.3
+# fetch_version (github.com/rvm/rvm bitbucket.org/mpapis/rvm) 1. -> 1.11.0
+# fetch_version (github.com/rvm/rvm bitbucket.org/mpapis/rvm) "" -> 2.0.1
fetch_version()
{
typeset _account _domain _pattern _repo _sources _values _version
@@ -824,7 +824,7 @@ rvm_install_main()
{
[[ -f ./scripts/install ]] ||
{
- log "'./scripts/install' can not be found for installation, something went wrong, it usally means your 'tar' is broken, please report it here: https://github.com/wayneeseguin/rvm/issues"
+ log "'./scripts/install' can not be found for installation, something went wrong, it usally means your 'tar' is broken, please report it here: https://github.com/rvm/rvm/issues"
return 127
}
View
@@ -45,4 +45,4 @@ RVM is supported by the following IDE products:
# Editing
To add a new implementation click "Edit this file" here:
-https://github.com/wayneeseguin/rvm/blob/master/help/alt.md
+https://github.com/rvm/rvm/blob/master/help/alt.md
View
@@ -44,5 +44,5 @@ Update RVM
## Examples
- rvm get branch shoes # will fetch branch shoes from wayneeseguin/rvm repo
+ rvm get branch shoes # will fetch branch shoes from rvm/rvm repo
rvm get branch mpapis/ # will fetch branch master from mpapis/rvm repo
@@ -64,6 +64,6 @@ Replace `google.com` with your server address
## Reporting bugs
-Please report issues to https://github.com/wayneeseguin/rvm/issues
+Please report issues to https://github.com/rvm/rvm/issues
In case of security issues use rvm-internal@googlegroups.com
@@ -9,6 +9,6 @@ then
__sitelib="$( $rvm_ruby_binary -rrbconfig -e "puts RbConfig::CONFIG['sitelibdir']" )"
if [[ -n "${__sitelib}" ]]
then touch "${__sitelib}/auto_gem.rb"
- else echo "WARN: Installed ruby does not have valid 'sitelibdir', no 'auto_gem.rb' was created, please report a bug here: https://github.com/wayneeseguin/rvm/issues"
+ else echo "WARN: Installed ruby does not have valid 'sitelibdir', no 'auto_gem.rb' was created, please report a bug here: https://github.com/rvm/rvm/issues"
fi
fi
View
@@ -172,7 +172,7 @@ then
rvm_fail "
No fallback URL can be calculated for ${url}, open a ticket with full output here:
- https://github.com/wayneeseguin/rvm/issues
+ https://github.com/rvm/rvm/issues
" $result
fi
@@ -256,7 +256,7 @@ __rvm_setup_compile_environment_system()
__rvm_setup_compile_environment_flags_docs()
{
- # disable docs, see https://github.com/wayneeseguin/rvm/issues/2656
+ # disable docs, see https://github.com/rvm/rvm/issues/2656
# enable docs on OSX by default (that's development system)
# if [[ "Darwin" == "${_system_type}" ]]
# then : rvm_docs_flag=${rvm_docs_flag:=1}
@@ -15,7 +15,7 @@ __rvm_setup_compile_environment_system_early_osx_old_rubies()
RVM does not know how to build working ${rvm_ruby_string} on OSX ${_system_version},
if you know please let us know by opening a ticket with instructions here:
- https://github.com/wayneeseguin/rvm/issues
+ https://github.com/rvm/rvm/issues
"
return 1
;;
@@ -110,7 +110,7 @@ __rvm_setup_compile_environment_system_SunOS()
__rvm_setup_compile_environment_system_OpenBSD()
{
- # https://github.com/wayneeseguin/rvm/issues/1581
+ # https://github.com/rvm/rvm/issues/1581
rvm_configure_env+=( sh )
case "$1" in
ruby-1.9*|ruby-2*)
@@ -27,7 +27,7 @@ __rvm_requirements_run_load()
[[ -s "$rvm_scripts_path/functions/requirements/${__type}" ]] ||
{
rvm_error "Requirements support for ${__type} is not implemented yet,
-report a bug here => https://github.com/wayneeseguin/rvm/issues"
+report a bug here => https://github.com/rvm/rvm/issues"
return 1
}
source "$rvm_scripts_path/functions/requirements/${__type}"
@@ -225,7 +225,7 @@ __rvm_requirements_run_custom_()
Can not find function 'requirements_${__lib_type}_install_${__custom}' to install missing ${__custom//_/ } packages:
${__missing_custom[*]}
report a bug here:
- https://github.com/wayneeseguin/rvm/issues
+ https://github.com/rvm/rvm/issues
" || return $?
fi
fi
@@ -178,7 +178,7 @@ Please do one of the following:
__rvm_remote_version()
{
- __rvm_curl -s --max-time 10 https://github.com/wayneeseguin/rvm/raw/master/VERSION || true
+ __rvm_curl -s --max-time 10 https://github.com/rvm/rvm/raw/master/VERSION || true
}
__rvm_cli_autoupdate_version_old()
@@ -184,7 +184,7 @@ __variables_definition()
${__method} "${__variables_list[@]}" || true
- # prevent errors with bash "set -a", see https://github.com/wayneeseguin/rvm/issues/2872
+ # prevent errors with bash "set -a", see https://github.com/rvm/rvm/issues/2872
if [[ -n "${BASH_VERSION:-}" ]]
then export -fn __rvm_select_version_variables __rvm_ruby_string_parse_ __rvm_rm_rf_verbose __rvm_parse_args 2>/dev/null || true
fi
@@ -1458,7 +1458,7 @@ update_yaml_if_needed()
! __rvm_grep -r "${yaml_version//\./\\.}" "${rvm_usr_path:=$rvm_path/usr}" >/dev/null 2>&1
then
__rvm_log_command "update_yaml" \
- " Updating libyaml in $rvm_usr_path to version $yaml_version, see https://github.com/wayneeseguin/rvm/issues/2594 " \
+ " Updating libyaml in $rvm_usr_path to version $yaml_version, see https://github.com/rvm/rvm/issues/2594 " \
install_libyaml
fi
}
@@ -4,7 +4,7 @@ ironruby_install()
{
rvm_error "WARNING! IronRuby is not anywhere around usable (with or without RVM),
there are multiple issues with it, here is an effort to improve/fix it:
- https://github.com/wayneeseguin/rvm/pull/1543"
+ https://github.com/rvm/rvm/pull/1543"
builtin command -v mono > /dev/null ||
{
@@ -34,7 +34,7 @@ requirements_centos_libs_install()
requirements_centos_before_update_check_repos_missing_error()
{
rvm_error "There is no '$*' package available for installation and RVM does not know how to make that happen,
-please tell us how to install '$*' on '${_system_name}-${_system_version}' here: https://github.com/wayneeseguin/rvm/issues"
+please tell us how to install '$*' on '${_system_name}-${_system_version}' here: https://github.com/rvm/rvm/issues"
return 49
}
@@ -58,7 +58,7 @@ requirements_pclinuxos_update_system_check_epel()
[[ -z "$epel_rpm" || -z "$epel_key" ]]
then
rvm_error "There is no 'libyaml-devel' package available for installation and RVM does not know how to make that happen,
-please tell us how to install 'libyaml-devel' on '${_system_name}-${_system_version}' here: https://github.com/wayneeseguin/rvm/issues"
+please tell us how to install 'libyaml-devel' on '${_system_name}-${_system_version}' here: https://github.com/rvm/rvm/issues"
return 49
fi
rvm_requiremnts_fail_or_run_action 2 \
@@ -38,7 +38,7 @@ ERROR: can not find 'pkg-config', it is required for autolibs rvm_pkg to work, i
}
rvm_warn "
Warning, you are using 'rvm autolibs rvm_pkg', this is rarely used and can produce errors,
-make sure to report any problems to https://github.com/wayneeseguin/rvm/issues
+make sure to report any problems to https://github.com/rvm/rvm/issues
"
}
@@ -80,7 +80,7 @@ __rvm_ruby_string_parse_()
__rvm_custom_separated_array strings - "${ruby_string}"
rvm_ruby_string="${ruby_string}"
- # +() in ZSH, see https://github.com/wayneeseguin/rvm/issues/2807
+ # +() in ZSH, see https://github.com/rvm/rvm/issues/2807
if [[ -n "${ZSH_VERSION:-}" ]]
then setopt LOCAL_OPTIONS KSH_GLOB
fi
@@ -56,7 +56,7 @@ __rvm_remove_from_path()
\typeset _value
_value="${1//+(\/)//}"
- # remove multiple slashes https://github.com/wayneeseguin/rvm/issues/1364
+ # remove multiple slashes https://github.com/rvm/rvm/issues/1364
if
[[ "$PATH" == *"//"* || "$PATH" == *"/:"* ]]
then
@@ -323,7 +323,7 @@ file_exists_at_url()
case ${__ret} in
(60)
# detect double --insecure and avoid duplication, see:
- # https://github.com/wayneeseguin/rvm/issues/2640#issuecomment-35669722
+ # https://github.com/rvm/rvm/issues/2640#issuecomment-35669722
file_exists_at_url_command "$1" || return $?
return 0
;;
View
@@ -236,7 +236,7 @@ $notes_type Notes:
then
important_message "
* WARNING: ${__user_shell} version 5.0.3 detected it is BROKEN, either downgrade or upgrade it,
- for details see => https://github.com/wayneeseguin/rvm/pull/2431
+ for details see => https://github.com/rvm/rvm/pull/2431
"
fi
@@ -261,7 +261,7 @@ $notes_type Notes:
fi
important_message "
* WARNING: ${__file} contains \`PATH=\` with no \`\$PATH\` inside, this can break RVM,
- for details check https://github.com/wayneeseguin/rvm/issues/1351#issuecomment-10939525
+ for details check https://github.com/rvm/rvm/issues/1351#issuecomment-10939525
to avoid this warning append #PATH.
"
fi | important_redirect
View
@@ -2,7 +2,7 @@
# rvm : Ruby enVironment Manager
# https://rvm.io
-# https://github.com/wayneeseguin/rvm
+# https://github.com/rvm/rvm
# partial duplication marker dkjnkjvnckbjncvbkjnvkj
# prevent from loading in sh shells
@@ -212,7 +212,7 @@ then
then
echo "
Warning: PATH set to RVM ruby but GEM_HOME and/or GEM_PATH not set, see:
- https://github.com/wayneeseguin/rvm/issues/3212
+ https://github.com/rvm/rvm/issues/3212
" >&2
if
[[ -n "${SUDO_USER:-}" ]]
View
@@ -16,7 +16,7 @@ go_to_temp()
download_from_github()
{
[[ -e ${last_release}.tar.gz ]] ||
- curl -OL https://github.com/wayneeseguin/rvm/archive/${last_release}.tar.gz
+ curl -OL https://github.com/rvm/rvm/archive/${last_release}.tar.gz
}
download_from_bitbucket()
@@ -52,7 +52,7 @@ remove_extra_files()
upload_github()
{
- echo "Upload ${last_release}.tar.gz.asc to: https://github.com/wayneeseguin/rvm/releases/new?tag=${last_release}"
+ echo "Upload ${last_release}.tar.gz.asc to: https://github.com/rvm/rvm/releases/new?tag=${last_release}"
}
upload_bitbucket()

0 comments on commit 92b9075

Please sign in to comment.