Permalink
Browse files

make sure requiremnents are run for proper ruby, fix #1465

  • Loading branch information...
1 parent e5cb916 commit e15fffbeb4ba108631c34fa83d579d297f6bdeb3 @mpapis mpapis committed Jan 24, 2013
Showing with 3 additions and 2 deletions.
  1. +2 −1 binscripts/rvm-installer
  2. +1 −1 scripts/cli
View
@@ -475,7 +475,8 @@ then
for _ruby in ${install_rubies[@]}
do
- rvm install ${_ruby} -j 2
+ rvm requirements run force ${_ruby}
+ command rvm install ${_ruby} -j 2
done
for _ruby in ${install_rubies[@]}
do
View
@@ -1080,7 +1080,7 @@ To reinstall use:
[[ $(find $rvm_rubies_path -maxdepth 1 -mindepth 1 -type d 2>/dev/null | wc -l) -eq 0 ]] &&
rvm_is_a_shell_function no_warning
then
- "$rvm_scripts_path"/requirements run
+ "$rvm_scripts_path"/requirements run force ${rvm_ruby_strings}
fi
__rvm_manage_wrapper install "${rvm_ruby_strings}"
fi

0 comments on commit e15fffb

Please sign in to comment.