Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Apr 14, 2015
  1. @havenwood
  2. @rys

    Merge pull request #3379 from rvm/code-of-conduct

    rys authored
    Code of conduct
  3. @rys
  4. @rys
  5. @mpapis

    sign the installer

    mpapis authored
Commits on Apr 13, 2015
  1. @mpapis

    Merge pull request #3375 from rvm/update-known-rubies

    mpapis authored
    Update known rubies to 2.0.0p645, 2.1.6, and 2.2.2
  2. @sikachu

    Update known rubies to 2.0.0p645, 2.1.6, and 2.2.2

    sikachu authored
    These are the latest releases of MRI as of 2015-04-13.
  3. @mpapis

    Merge pull request #3374 from rvm/1-9-3-security-backport

    mpapis authored
    Backport CVE-2015-1833 to Ruby 1.9.3-p484+
  4. @sikachu

    Backport CVE-2015-1833 to Ruby 1.9.3-p484+

    sikachu authored
    This is a backport of ruby/ruby@599bfa7
    for Ruby 1.9.3. It only applies to these patchlevels:
    
    * 1.9.3-p484
    * 1.9.3-p545
    * 1.9.3-p547
    * 1.9.3-p550
    * 1.9.3-p551
  5. @havenwood
  6. @mpapis

    Merge pull request #3373 from rvm/fix-rubygems-on-2-2-2

    mpapis authored
    Add fix_installing_bundled_gems patch for Ruby 2.2.2
  7. @mpapis

    Merge pull request #3364 from bezeek/bugfix/cygwin_rvm-installer_gpg_…

    mpapis authored
    …detection
    
    Added some missing ${}s to install scripts
  8. @sikachu
Commits on Apr 12, 2015
  1. @rys

    Project Code of Conduct

    rys authored
Commits on Apr 1, 2015
  1. @bezeek
Commits on Mar 30, 2015
  1. @mpapis

    Merge branch 'hotfix/1.26.11'

    mpapis authored
  2. @mpapis
  3. @mpapis

    1.26.11

    mpapis authored
  4. @mpapis

    Merge pull request #3362 from havenwood/zlib

    mpapis authored
    Added -lz to ruby build flags
  5. @mpapis

    Merge pull request #3359 from havenwood/os-x-binaries

    mpapis authored
    Added checksums for additional OS X binaries
  6. @havenwood
  7. @havenwood

    add -lz to ruby build flags

    havenwood authored
    This prevents an openssl bug where it requires -lz when it's statically linked but it isn't available by default.
    
    For example, this was causing issues with building the puma gem:
    ```ruby
     require 'mkmf'
    
     have_library 'crypto', 'BIO_read'
     #>> checking for BIO_read() in -lcrypto... yes
     #=> true
    
     # The puma build fails here:
     have_library 'ssl', 'SSL_CTX_new'
     #>> checking for SSL_CTX_new() in -lssl... no
     #=> false
    
     # With zlib it succeeds:
     have_library 'z'
     #>> checking for main() in -lz... yes
     #=> true
    
     have_library 'ssl', 'SSL_CTX_new'
     #>> checking for SSL_CTX_new() in -lssl... yes
     #=> true
    ```
Commits on Mar 24, 2015
  1. @mpapis
  2. @mpapis
  3. @mpapis

    Merge pull request #3340 from killphi/fix_trap_behavior

    mpapis authored
    Fix trap behavior
  4. @mpapis

    Merge pull request #3341 from skaes/railsexpress-patches-for-ruby-2.2.1

    mpapis authored
    Railsexpress patches for ruby 2.2.1
Commits on Mar 23, 2015
  1. @mpapis

    Merge pull request #3355 from MSch/fix-installing-bundled-gems-2.2.1

    mpapis authored
    Add fix_installing_bundled_gems.patch for Ruby 2.2.1
  2. @MSch
Commits on Mar 18, 2015
  1. @mpapis

    Merge pull request #3350 from havenwood/gcc49

    mpapis authored
    Bump GCC version from 4.8 to 4.9 for OS X 10.10+
  2. @havenwood

    Bump GCC version from 4.8 to 4.9 for OS X 10.10+

    havenwood authored
    Closes #3349.
    
    Add 4.9 in addition to 4.8 instead of replacing it.
Commits on Mar 10, 2015
  1. @skaes
  2. @skaes
Commits on Mar 9, 2015
  1. @mpapis

    Merge pull request #3338 from jrgifford/use_the_cdn_for_binaries

    mpapis authored
    Use the CDN for binaries. Related to rvm/rvm-site-setup#1
  2. @killphi
  3. @killphi
Something went wrong with that request. Please try again.