jruby install fails when running jruby_install_build_nailgun #1153

Closed
drnic opened this Issue Sep 28, 2012 · 12 comments

Projects

None yet

7 participants

@drnic
drnic commented Sep 28, 2012
> rvm reinstall jruby
Removing /Users/drnic/.rvm/src/jruby-1.6.8...
Removing /Users/drnic/.rvm/rubies/jruby-1.6.8...
jruby-1.6.8 - #downloading jruby-bin-1.6.8, this may take a while depending on your connection...
jruby-1.6.8 - #extracting jruby-bin-1.6.8 to /Users/drnic/.rvm/src/jruby-1.6.8
jruby-1.6.8 - #extracted to /Users/drnic/.rvm/src/jruby-1.6.8
jruby-1.6.8 - #nailgun
Error running 'jruby_install_build_nailgun', please read /Users/drnic/.rvm/log/jruby-1.6.8/nailgun.log
'rvm_codesign_identity' is not set, please set it in ~/.rvmrc
> cat /Users/drnic/.rvm/log/jruby-1.6.8/nailgun.log
[2012-09-27 18:25:39] jruby_install_build_nailgun
env: : No such file or directory
@mpapis
Member
mpapis commented Sep 28, 2012

what shell / version are you running?

@tobias
tobias commented Sep 29, 2012

I see the same issue under zsh (on MacOS and Linux), but switching to bash (at least on Linux) allows the installation to complete. I'm using prezto with zsh; I don't know if that is interfering.

@drnic
drnic commented Sep 29, 2012

@mpapis zsh 4.3.17 (x86_64-apple-darwin11.3.0)

@drnic
drnic commented Sep 29, 2012

Confirmed - if I switch to bash the installation works.

@mpapis mpapis was assigned Sep 30, 2012
@jrgifford
Member

Confirmed with zsh, and if I switch to bash the install works.

@pkieltyka

Same issue with me.. except im trying to install jruby-head

@mpapis mpapis closed this in 11fa8b5 Oct 3, 2012
@mpapis
Member
mpapis commented Oct 3, 2012

I have released 1.15.11 to fix jruby-head compilation issues, working now on fixing fully 1.16.

@mpapis mpapis reopened this Oct 3, 2012
@mpapis mpapis closed this in e65b266 Oct 3, 2012
@mpapis mpapis added a commit that referenced this issue Oct 3, 2012
@mpapis mpapis clean last zsh chpwd function traces, fix #1153
Conflicts:
	scripts/functions/manage/base
81662c0
@mpapis
Member
mpapis commented Oct 3, 2012

1.16.7 released:

rvm get stable
rvm reload

and try again

@robinroestenburg

I'm running into the same problem when using rvm 1.16.13 and zsh. Is there some regression?

Here is the output when re-installing JRuby 1.6.8:

/Users/robin/.rvm/src/jruby-1.6.8 has already been removed.
/Users/robin/.rvm/rubies/jruby-1.6.8 has already been removed.
jruby-1.6.8 - #downloading jruby-bin-1.6.8, this may take a while depending on your connection...
jruby-1.6.8 - #extracting jruby-bin-1.6.8 to /Users/robin/.rvm/src/jruby-1.6.8
mv: rename /Users/robin/.rvm/tmp/rvm_src_86479/\033]1;~/.rvm/tmp/rvm_src_86479\a\033]2;~/.rvm/tmp/rvm_src_86479\ajruby-1.6.8 to /Users/robin/.rvm/src/jruby-1.6.8: No such file or directory
jruby-1.6.8 - #extracted to /Users/robin/.rvm/src/jruby-1.6.8
jruby_install:cd:34: no such file or directory: /Users/robin/.rvm/src/jruby-1.6.8
jruby-1.6.8 - #nailgun
Error running 'jruby_install_build_nailgun', please read /Users/robin/.rvm/log/jruby-1.6.8/nailgun.log
Making gemset jruby-1.6.8 pristine.
@mpapis
Member
mpapis commented Oct 15, 2012

@robinroestenburg this looks like a different issue, please open a new ticket so we can track progress separately

@sgentile
sgentile commented Apr 2, 2013

rvm install jruby --1.9
Password:
Cloning from git://github.com/jruby/jruby.git, this may take a while depending on your connection...
HEAD is now at c7c3266 Merge pull request #622 from fooblahblah/timeout-worker-pool-size
From git://github.com/jruby/jruby

  • branch master -> FETCH_HEAD
    Already up-to-date.
    Copying from repo to src path...
    jruby-1.7.2 - #ant jar
    jruby-1.7.2 - #ant jar -Djruby.default.ruby.version=1.9
    jruby-1.7.2 - #ant cext
    jruby-1.7.2 - #nailgun
    Error running 'jruby_install_build_nailgun', please read /usr/local/rvm/log/jruby-1.7.2/nailgun.log
@mpapis
Member
mpapis commented Apr 2, 2013

@sgentile please open a new ticket

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment