installation stuck on Compiling yaml #1154

Closed
sylv3rblade opened this Issue Sep 28, 2012 · 6 comments

Comments

Projects
None yet
3 participants

on rvm 1.16.5 and Mountain Lion with xcode 4.5

No binary rubies available for: ///ruby-1.9.2-p320.
Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies.
Fetching yaml-0.1.4.tar.gz to /Users/sylv3rblade/.rvm/archives
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  460k  100  460k    0     0   107k      0  0:00:04  0:00:04 --:--:--  113k
Extracting yaml-0.1.4.tar.gz to /Users/sylv3rblade/.rvm/src
Configuring yaml in /Users/sylv3rblade/.rvm/src/yaml-0.1.4
Compiling yaml in /Users/sylv3rblade/.rvm/src/yaml-0.1.4
Owner

mpapis commented Sep 28, 2012

try with both stable and head - if both fail please provide a gist of:

rvm --trace install 1.9.2

on stable:
still got stuck. Trace here: http://pastebin.com/d38hZpeJ

on head, got 1.16.6 installed and it worked fine.

Owner

mpapis commented Sep 28, 2012

So the issue is fixed on head? ... all the simple changes were merged back to stable so I guess one of the bigger changes did the trick, for now please stick with rvm head.

@mpapis mpapis closed this Sep 28, 2012

@ghost ghost assigned mpapis Sep 28, 2012

I have the same problem and I can't get it to work using rvm head. Here's a trace and rvm debug info : https://gist.github.com/3815533

Owner

mpapis commented Oct 3, 2012

@jbourassa can you run this:

rvm get head
rvm reload
rvm pkg install libyaml

It should be already fixed with the last commit.

Right, libyaml works, thanks for the fix =). I am still having other issues though =/

I managed to compile with rbenv so I am not in a hurry but you may still want to look in this issue.

$ rvm install 1.9.3 --with-readline-dir=/usr/local/include/readline 

rvm:262: no matches found: /Users/jbourassa/.rvm/rubies/*/bin/ruby
Installing Ruby from source to: /Users/jbourassa/.rvm/rubies/ruby-1.9.3-p194, this may take a while depending on your cpu(s)...
ruby-1.9.3-p194 - #downloading ruby-1.9.3-p194, this may take a while depending on your connection...



ruby-1.9.3-p194 - #extracting ruby-1.9.3-p194 to /Users/jbourassa/.rvm/src/ruby-1.9.3-p194
ruby-1.9.3-p194 - #extracted to /Users/jbourassa/.rvm/src/ruby-1.9.3-p194
Skipping configure step, 'configure' does not exist, did autoreconf not run successfully?
ruby-1.9.3-p194 - #compiling
Error running 'make', please read /Users/jbourassa/.rvm/log/ruby-1.9.3-p194/make.log
There has been an error while running make. Halting the installation.
rvm:319: no matches found: /Users/jbourassa/.rvm/rubies/*/bin/ruby
$ cat /Users/jbourassa/.rvm/log/ruby-1.9.3-p194/make.log
[2012-10-03 10:49:46] make
make: *** No targets specified and no makefile found.  Stop.

mpapis added a commit that referenced this issue Oct 3, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment