No binary rubies available for: ///ruby-1.9.3-p194. #1179

Closed
Bunlong-Cambodia opened this Issue Oct 2, 2012 · 7 comments

Projects

None yet

4 participants

@Bunlong-Cambodia

when I install ruby with command "rvm install 1.9.3" I get this error in yellow "No binary rubies available for: ///ruby-1.9.3-p194. Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies".

After install I got:

Removing /home/bunlong/.rvm/src/ruby-1.9.3-p194...
Removing /home/bunlong/.rvm/rubies/ruby-1.9.3-p194...
No binary rubies available for: ///ruby-1.9.3-p194.
Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies.
Installing Ruby from source to: /home/bunlong/.rvm/rubies/ruby-1.9.3-p194, this may take a while depending on your cpu(s)...
ruby-1.9.3-p194 - #downloading ruby-1.9.3-p194, this may take a while depending on your connection...
ruby-1.9.3-p194 - #extracting ruby-1.9.3-p194 to /home/bunlong/.rvm/src/ruby-1.9.3-p194
ruby-1.9.3-p194 - #extracted to /home/bunlong/.rvm/src/ruby-1.9.3-p194
ruby-1.9.3-p194 - #configuring
ruby-1.9.3-p194 - #compiling
ruby-1.9.3-p194 - #installing
Removing old Rubygems files...
Installing rubygems-1.8.24 for ruby-1.9.3-p194 ...
Installation of rubygems completed successfully.
Saving wrappers to '/home/bunlong/.rvm/bin'.
ruby-1.9.3-p194 - #adjusting #shebangs for (gem irb erb ri rdoc testrb rake).
ruby-1.9.3-p194 - #importing default gemsets (/home/bunlong/.rvm/gemsets/)
Install of ruby-1.9.3-p194 - #complete
Making gemset ruby-1.9.3-p194 pristine.
Making gemset ruby-1.9.3-p194@global pristine.

Thank,

@mpapis
Ruby enVironment Manager member

duplicate of #1174, and should be already fixed, please try with both following commands and let me know if after any it still fails:

rvm get head
rvm reload

and:

rvm get stable
rvm reload
@mpapis mpapis was assigned Oct 3, 2012
@mpapis
Ruby enVironment Manager member

fixed with 3534786

@amalagaura

I tried with rvm head and rvm stable and it does not find ruby-1.9.3 binaries on OSX 10.6.8

head: No binary rubies available for: /ruby-1.9.3-p194.
stable: No binary rubies available for: ///ruby-1.9.3-p194.

The compilation does succeed.

@mpapis mpapis closed this Oct 7, 2012
@akmur

same issue, ubuntu 10.04, 11.10, 12.04

@mpapis
Ruby enVironment Manager member

@akmur what version of rvm? and what exactly is your issue?

@akmur

I install rvm through:

curl -L get.rvm.io | bash -s stable --auto

@mpapis
Ruby enVironment Manager member

@akmur update with:

rvm get head

and can you describe what is your problem

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment