Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Binaries for Debian Wheezy (64 bits) #1204

Closed
ayosec opened this Issue · 5 comments

2 participants

@ayosec

There are no binaries for Debian on Wheezy/sid for the 64 bits.

$ rvm list remote

# No remote rubies available. Check 'rvm list known' for what can be installed.

The machine:

$ rvm info system

system:

  system:
    uname:       "Linux  3.2.0-2-amd64 #1 SMP Mon Jun 11 17:24:18 UTC 2012 x86_64 GNU/Linux"
    system:      "debian/wheezy_sid/x86_64"
    bash:        "/bin/bash => GNU bash, versión 4.2.37(1)-release (x86_64-pc-linux-gnu)"
    zsh:         " => not installed"

There are binaries for other Debian systems:

$ __list_remote_rubies_for | grep debian
https://rvm.io/binaries/debian/6.0.4/x86_64/ruby-1.9.3-p194.tar.bz2
https://rvm.io/binaries/debian/wheezy_sid/armv6l/ruby-1.9.2-p320.tar.bz2
https://rvm.io/binaries/debian/wheezy_sid/armv6l/ruby-1.9.3-p194.tar.bz2
@mpapis mpapis was assigned
@mpapis
Owner

we will provide build as soon as the binary rubies stabilizes (there are few issues that need to be fixed first), but it should not be longer then end of next week.

for the command grep was not needed - __list_remote_rubies_for debian - is enough.

can you point me to an proper vagrant/xen image for your platform (might be from http://www.vagrantbox.es/)

@ayosec

It seems that there is no official image. In the Debian Wiki I found an image for Debian Wheeze.

I tried it. The vagrant up prints some warnings, but it works well.

@mpapis
Owner

added in here mpapis/rvm-binary@e8cd6d5#distributions.yml - not tested yet, but will be available ass soon I can push it

@mpapis
Owner

RVM 1.16.14 contains new set of binary rubies, please try again:

rvm get stable
rvm reload
rvm reinstall 1.9.3
@ayosec

It works like a charm. Thanks you!

$ rvm list remote

# Rubies available for 'debian/wheezy_sid/x86_64':

   ruby-1.9.3-p194
   ruby-1.9.3-p286

# * - installed already

# To download and install: rvm install {name} --binary

$ rvm install ruby-1.9.3-p286 --binary
ruby-1.9.3-p286 - #configure
ruby-1.9.3-p286 - #download
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 4980k  100 4980k    0     0   618k      0  0:00:08  0:00:08 --:--:--  973k
ruby-1.9.3-p286 - #extract
ruby-1.9.3-p286 - #validate
ruby-1.9.3-p286 - #setup
Saving wrappers to '/home/ayosec/.rvm/bin'.
ruby-1.9.3-p286 - #importing default gemsets (/home/ayosec/.rvm/gemsets/)
$ rvm use ruby-1.9.3-p286 
Using /home/ayosec/.rvm/gems/ruby-1.9.3-p286
$ ruby -v
ruby 1.9.3p286 (2012-10-12 revision 37165) [x86_64-linux]
@ayosec ayosec closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.