Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Newly included Ruby 1.9.3-p286 'cflags.patch' FAILS. Does NOT apply #1270

Closed
ddd opened this Issue Oct 26, 2012 · 2 comments

Comments

Projects
None yet
3 participants
Contributor

ddd commented Oct 26, 2012

Attempting to add the cflags patch to MRI 1.9.3-p286 fails. See 'CFLAGS patch does not apply cleanly against 1.9.3-p286 with OR without falcon patch' gist located at: https://gist.github.com/6550793026224b4e2b90

Contributor

ddd commented Oct 26, 2012

OK, its seems that the way to get the patch to install correctly is to specify it using the ---movable flag as follows:

rvm install 1.9.3-p286 --movable --patch falcon

This works perfectly, both as an initial rvm install, and as a rvm reinstall option. Tested and works.

@lemoinem lemoinem closed this Oct 26, 2012

Owner

mpapis commented Oct 27, 2012

reopening - we need to make sure that duplicate patch names are not applied twice.

@mpapis mpapis reopened this Oct 27, 2012

@mpapis mpapis closed this in 14c9596 Oct 27, 2012

@ghost ghost assigned mpapis Oct 27, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment